summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Plant2021-03-07 19:24:40 +0000
committerRobert Plant2021-03-07 19:24:40 +0000
commit7638eded1a126d3052409d084ed0fe79d3977b10 (patch)
treeb7cca623511b06d673cc9a095d6cc61a9b87ac15
parent7078cc1f3a03e4d59a78b86718dbf27fd2c56631 (diff)
downloadaur-7638eded1a126d3052409d084ed0fe79d3977b10.tar.gz
Update build to use install instead of cargo bin.
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a19b6ac15203..8e988266e622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,13 @@ check() {
cargo test --release
}
+build() {
+ cd $pkgname-$pkgver
+ cargo build --release
+}
+
package() {
cd $pkgname-$pkgver
- cargo install --path .
+ install -D target/release/paswitch-rs -t "$pkgdir"/usr/bin
+ install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/paswitch-rs
}