summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2015-05-06 13:16:03 +0300
committerChristoph Gysin2015-06-14 12:05:19 +0300
commit90dbfc8e834fb3d3d989b0cd728532542dd58ff8 (patch)
tree35518cb599022ab7304b425d19d354616c73f3d8
downloadaur-90dbfc8e834fb3d3d989b0cd728532542dd58ff8.tar.gz
initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD63
-rw-r--r--pasystray.install11
4 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2dd59198b994
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = pasystray-git
+ pkgdesc = PulseAudio system tray (a replacement for padevchooser)
+ pkgver = 0.5.2.r0.g6709fc1
+ pkgrel = 1
+ url = https://github.com/christophgysin/pasystray
+ install = pasystray.install
+ arch = i686
+ arch = x86_64
+ groups = multimedia
+ license = LGPL
+ makedepends = git
+ makedepends = pkg-config
+ depends = libpulse
+ depends = gtk3
+ depends = libnotify
+ depends = avahi
+ depends = libx11
+ depends = gnome-icon-theme
+ depends = gtk-update-icon-cache
+ optdepends = paman: Launch PulseAudio manager from tray icon
+ optdepends = pavucontrol: Launch PulseAudio mixer from tray icon
+ optdepends = pavumeter: Launch PulseAudio volume meter from tray icon
+ optdepends = paprefs: Launch PulseAudio preferences from tray icon
+ provides = pasystray
+ conflicts = pasystray
+ source = git+https://github.com/christophgysin/pasystray.git
+ md5sums = SKIP
+
+pkgname = pasystray-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0c48a10ff4cd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pasystray-*.tar.*
+pasystray/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e23ce4e07e32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
+_pkgname=pasystray
+pkgname=${_pkgname}-git
+pkgver=0.5.2.r0.g6709fc1
+pkgrel=1
+pkgdesc="PulseAudio system tray (a replacement for padevchooser)"
+arch=('i686' 'x86_64')
+url="https://github.com/christophgysin/pasystray"
+license=('LGPL')
+groups=('multimedia')
+depends=('libpulse' 'gtk3' 'libnotify' 'avahi' 'libx11' 'gnome-icon-theme'
+ 'gtk-update-icon-cache')
+makedepends=('git' 'pkg-config' )
+optdepends=(
+ 'paman: Launch PulseAudio manager from tray icon'
+ 'pavucontrol: Launch PulseAudio mixer from tray icon'
+ 'pavumeter: Launch PulseAudio volume meter from tray icon'
+ 'paprefs: Launch PulseAudio preferences from tray icon'
+)
+provides=('pasystray')
+conflicts=('pasystray')
+backup=()
+options=()
+install='pasystray.install'
+source=(git+https://github.com/christophgysin/pasystray.git)
+noextract=()
+md5sums=('SKIP')
+
+_gitroot=git://github.com/christophgysin/${pkgname%-git}.git
+_gitname=${pkgname%-git}
+
+pkgver() {
+ cd $_pkgname
+ git describe --long | sed -r "s/^${pkgname%-git}-//;s/([^-]*-g)/r\\1/;s/-/./g"
+}
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+ if [[ -d $_gitname ]]; then
+ cd $_gitname
+ git fetch
+ git reset --hard origin/master
+ msg "The local files are updated."
+ else
+ git clone --depth=1 $_gitroot $_gitname
+ fi
+ msg "GIT checkout done or server timeout"
+ cd "$srcdir/$_gitname"
+
+ aclocal
+ autoconf
+ autoheader
+ automake --add-missing
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/pasystray.install b/pasystray.install
new file mode 100644
index 000000000000..9bd8fff53488
--- /dev/null
+++ b/pasystray.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}