summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-21 14:30:50 +0800
committerChocobo12017-08-21 15:41:19 +0800
commit7fd5dc74348cf8ce179640c47da67be307a88ae7 (patch)
treeff2f5eed18bbba39b696f33b38e7b57fc76afb0f
downloadaur-7fd5dc74348cf8ce179640c47da67be307a88ae7.tar.gz
newpkg: patch-git 2.7.5.r17.g817d7d1-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25672379ab01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = patch-git
+ pkgdesc = A utility to apply patch files to original sources
+ pkgver = 2.7.5.r17.g817d7d1
+ pkgrel = 1
+ url = https://www.gnu.org/software/patch/patch.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = gettext
+ depends = glibc
+ depends = attr
+ provides = patch
+ conflicts = patch
+ source = git+https://git.savannah.gnu.org/git/patch.git
+ sha256sums = SKIP
+
+pkgname = patch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3f4c218438d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=patch-git
+pkgver=2.7.5.r17.g817d7d1
+pkgrel=1
+pkgdesc="A utility to apply patch files to original sources"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/patch/patch.html"
+license=('GPL3')
+depends=('glibc' 'attr')
+makedepends=('git' 'gettext')
+provides=('patch')
+conflicts=('patch')
+source=("git+https://git.savannah.gnu.org/git/patch.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "patch"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "patch"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "patch"
+
+ make check
+}
+
+package() {
+ cd "patch"
+
+ make DESTDIR="$pkgdir" install
+}