summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-08-27 16:46:01 +0200
committerChristopher Arndt2022-08-27 16:46:01 +0200
commit270a825a4cb32f88b208d30fb5bbfd55ac5e5179 (patch)
tree0eb9d275d1471503a3c99977bf4031fd485a936c
downloadaur-270a825a4cb32f88b208d30fb5bbfd55ac5e5179.tar.gz
Add new VCS package 'patchance-git'
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD49
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f46afdab72a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = patchance-git
+ pkgdesc = A modern graphical patchbay for JACK (git version)
+ pkgver = r51.14719a7
+ pkgrel = 1
+ url = https://github.com/Houston4444/Patchance
+ arch = any
+ groups = pro-audio
+ license = GPL2
+ makedepends = git
+ makedepends = qt5-tools
+ depends = python-pyqt5
+ provides = patchance
+ conflicts = patchance
+ source = patchance::git+https://github.com/Houston4444/Patchance.git
+ source = HoustonPatchbay::git+https://github.com/Houston4444/HoustonPatchbay.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = patchance-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d99d68dffb73
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+HoustonPatchbay/
+patchance/
+patchance-git-*.pkg.tar.xz
+patchance-git-*.pkg.tar.zst
+patchance-git-*.src.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e767baf73bbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=patchance
+pkgname="$_pkgname-git"
+pkgver=r51.14719a7
+pkgrel=1
+pkgdesc='A modern graphical patchbay for JACK (git version)'
+arch=(any)
+url='https://github.com/Houston4444/Patchance'
+license=(GPL2)
+depends=(python-pyqt5)
+makedepends=(git qt5-tools)
+groups=(pro-audio)
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$_pkgname::git+https://github.com/Houston4444/Patchance.git"
+ 'HoustonPatchbay::git+https://github.com/Houston4444/HoustonPatchbay.git')
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd $_pkgname
+ (
+ set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd $_pkgname
+ git submodule init
+ git config submodule.HoustonPatchbay.url "$srcdir"/HoustonPatchbay
+ git submodule update
+}
+
+build() {
+ cd $_pkgname
+ make
+}
+
+package() {
+ cd $_pkgname
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ # remove unneeded files from installation
+ rm -rf "$pkgdir"/usr/share/patchance/HoustonPatchbay/patchbay
+ rm -f "$pkgdir"/usr/share/patchance/HoustonPatchbay/{.git,.gitignore,Makefile,readme.md}
+ rm -rf "$pkgdir"/usr/share/patchance/HoustonPatchbay/manual
+}