summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Bundy2018-08-06 16:02:39 -0700
committerChristian Bundy2018-08-06 16:02:39 -0700
commit20d0caeb7e3592b87dc588be80f016452f684d2f (patch)
tree86cf617341f0e7a8bfbb1fe9880071a4ebdbfe5a
parent1206b4e09163c5c2497fba1aa782d45210e77169 (diff)
downloadaur-20d0caeb7e3592b87dc588be80f016452f684d2f.tar.gz
Depend on system Electron
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--run.sh2
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 397244f42940..17031ba1149d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = patchbay-git
pkgdesc = An alternative Secure Scuttlebutt client interface that is fully compatible with Patchwork
pkgver = 7.13.1.r201.7e29e0b
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ssbc/patchbay
arch = i686
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = patchbay-git
depends = gtk2
depends = gconf
depends = python
+ depends = electron
provides = patchbay
conflicts = patchbay
options = !strip
@@ -20,7 +21,7 @@ pkgbase = patchbay-git
source = run.sh
source = patchbay.desktop
md5sums = SKIP
- md5sums = 6632351cad7b33d94834e9a37f77f727
+ md5sums = 1f9644b6941ee0dbd55e4cda6a69604e
md5sums = f459479fef0987c5fa81a38b04767ffa
pkgname = patchbay-git
diff --git a/PKGBUILD b/PKGBUILD
index dec0f7079b95..9bffa169a9b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url="https://github.com/ssbc/patchbay"
license=('MIT')
provides=('patchbay')
conflicts=('patchbay')
-depends=('libsodium' 'gtk2' 'gconf' 'python')
+depends=('libsodium' 'gtk2' 'gconf' 'python' 'electron')
makedepends=('nodejs' 'npm' 'git')
options=(!strip)
_srcname=patchbay
@@ -20,7 +20,7 @@ source=(
)
md5sums=('SKIP'
- '6632351cad7b33d94834e9a37f77f727'
+ '1f9644b6941ee0dbd55e4cda6a69604e'
'f459479fef0987c5fa81a38b04767ffa')
pkgver() {
@@ -30,7 +30,7 @@ pkgver() {
build() {
cd "${srcdir}/${_srcname}"
- npm ci
+ npm ci --only=production
npm run rebuild
}
diff --git a/run.sh b/run.sh
index 2ba70b411f38..1732898b1281 100644
--- a/run.sh
+++ b/run.sh
@@ -1,4 +1,4 @@
#!/bin/bash
cd /opt/patchbay-git
-./node_modules/.bin/electron index.js "$@"
+exec electron index.js index.js "$@"