summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Bundy2018-07-17 19:25:05 -0700
committerChristian Bundy2018-07-17 19:25:05 -0700
commit5a7e3557a3e14a9f51a69706b103c38c5d757293 (patch)
tree99124b88efeab77a541ac1ebdcb5b1a5e36ca443
downloadaur-5a7e3557a3e14a9f51a69706b103c38c5d757293.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD37
-rw-r--r--patchbay.desktop11
-rw-r--r--run.sh4
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e3778b478d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = patchbay
+ pkgdesc = An alternative Secure Scuttlebutt client interface that is fully compatible with Patchwork
+ pkgver = 7.13.1
+ pkgrel = 1
+ url = https://github.com/ssbc/patchbay
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = nodejs
+ makedepends = npm
+ depends = libsodium
+ depends = gtk2
+ depends = gconf
+ depends = python
+ depends = lib32-gcc-libs
+ options = !strip
+ source = https://github.com/ssbc/patchbay/archive/v7.13.1.tar.gz
+ source = run.sh
+ source = patchbay.desktop
+ md5sums = 6ad303f916136ac12d53e1058be25798
+ md5sums = fae47b2d8539295743f7946ea07393c4
+ md5sums = f459479fef0987c5fa81a38b04767ffa
+
+pkgname = patchbay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..114df9e43ae1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Christian Bundy <christianbundy@fraction.io>
+
+pkgname=patchbay
+pkgver=7.13.1
+pkgrel=1
+pkgdesc="An alternative Secure Scuttlebutt client interface that is fully compatible with Patchwork "
+arch=('i686' 'x86_64')
+url="https://github.com/ssbc/patchbay"
+license=('MIT')
+depends=('libsodium' 'gtk2' 'gconf' 'python' 'lib32-gcc-libs')
+makedepends=('nodejs' 'npm')
+options=(!strip)
+source=(
+"https://github.com/ssbc/${pkgname}/archive/v${pkgver}.tar.gz"
+'run.sh'
+"${pkgname}.desktop"
+)
+
+md5sums=('6ad303f916136ac12d53e1058be25798'
+ 'fae47b2d8539295743f7946ea07393c4'
+ 'f459479fef0987c5fa81a38b04767ffa')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ npm ci
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -a * "${pkgdir}/opt/${pkgname}"
+ install -D assets/icon.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${pkgname}.png"
+
+ cd "${srcdir}"
+ install -D run.sh "${pkgdir}/usr/bin/${pkgname}"
+ install -D "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/patchbay.desktop b/patchbay.desktop
new file mode 100644
index 000000000000..a39b725d946c
--- /dev/null
+++ b/patchbay.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Patchbay
+Comment=An alternative Secure Scuttlebutt client interface that is fully compatible with Patchwork
+Exec=patchbay
+Icon=patchbay
+Terminal=false
+StartupNotify=false
+Categories=Network;Application;
+
diff --git a/run.sh b/run.sh
new file mode 100644
index 000000000000..8566be80b2b9
--- /dev/null
+++ b/run.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/patchbay
+./node_modules/.bin/electron index.js "$@"