summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2017-10-25 01:03:45 +0200
committerDavid Runge2017-10-25 01:03:45 +0200
commit6248dbe00f28c03fd5c12c3381ac1ff304ff3df5 (patch)
tree56b70aeb53e84da824c3847388f434c06f134c1a
parent9bbd28a86935540c3528d950b35dd26a1b21c2c3 (diff)
downloadaur-patchbook-git.tar.gz
PKGBUILD: Moving creation of executable script to prepare(). Cleaning up use of install. Cloning source to pkgname directory.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bbc34f86adf..5f13e6423d29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Tue Oct 17 09:54:30 UTC 2017
+# Tue Oct 24 23:02:45 UTC 2017
pkgbase = patchbook-git
pkgdesc = Markup language and parser for writing and distributing patches for modular synthesizers.
pkgver = r24.574b100
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/SpektroAudio/Patchbook
arch = any
license = MIT
depends = python
- source = patchbook-git-r24.574b100::git+https://github.com/spektroaudio/patchbook
+ source = patchbook-git::git+https://github.com/spektroaudio/patchbook
sha512sums = SKIP
pkgname = patchbook-git
diff --git a/PKGBUILD b/PKGBUILD
index 657608ae981b..465bc55695dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,45 +3,40 @@
pkgname=patchbook-git
_pkg=patchbook
pkgver=r24.574b100
-pkgrel=2
+pkgrel=3
pkgdesc="Markup language and parser for writing and distributing patches for modular synthesizers."
arch=('any')
url="https://github.com/SpektroAudio/Patchbook"
license=('MIT')
depends=('python')
-source=("$pkgname-$pkgver::git+https://github.com/spektroaudio/${_pkg}")
+source=("${pkgname}::git+https://github.com/spektroaudio/${_pkg}")
sha512sums=('SKIP')
pkgver() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}"
( set -o pipefail
git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
-build() {
- cd "$pkgname-$pkgver"
+prepare(){
+ cd "${pkgname}"
echo "#!/usr/bin/python3" > patchbook
cat patchbook.py >> patchbook
-
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${pkgname}"
# script
- install -Dm755 patchbook "$pkgdir/usr/bin/patchbook"
+ install -Dm0755 "${_pkg}" "${pkgdir}/usr/bin/${_pkg}"
# examples
- install -d "${pkgdir}/usr/share/doc/${_pkg}"
- install -Dm644 Examples/* \
- "$pkgdir/usr/share/doc/${_pkg}/"
+ install -t "${pkgdir}/usr/share/doc/${_pkg}/" -Dm0644 Examples/*
# license
- install -d "${pkgdir}/usr/share/licenses/${_pkg}"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_pkg}/LICENSE"
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${_pkg}/LICENSE"
# README
- install -Dm644 README.md \
- "$pkgdir/usr/share/doc/${_pkg}/README.md"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${_pkg}/README.md"
}