summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2017-09-08 19:54:10 +0200
committerDavid Runge2017-09-08 19:54:10 +0200
commitc929a7e65a2ada555c2b4c24c3c5dd14362e216f (patch)
tree659819049fc0a4f2890357bec7c36699b2af9845
downloadaur-c929a7e65a2ada555c2b4c24c3c5dd14362e216f.tar.gz
PKGBUILD: Adding patchbook-git.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f9658320a0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Fri Sep 8 17:53:51 UTC 2017
+pkgbase = patchbook-git
+ pkgdesc = Markup language and parser for writing and distributing patches for modular synthesizers.
+ pkgver = r24.574b100
+ pkgrel = 1
+ url = https://github.com/SpektroAudio/Patchbook
+ arch = any
+ license = MIT
+ depends = python
+ source = patchbook-git-r24.574b100::git+https://github.com/spektroaudio/patchbook
+ sha512sums = SKIP
+
+pkgname = patchbook-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1004046d10f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer : David Runge <dave@sleepmap.de>
+
+pkgname=patchbook-git
+_pkg=patchbook
+pkgver=r24.574b100
+pkgrel=1
+pkgdesc="Markup language and parser for writing and distributing patches for modular synthesizers."
+arch=('any')
+url="https://github.com/SpektroAudio/Patchbook"
+license=('MIT')
+depends=('python')
+source=("$pkgname-$pkgver::git+https://github.com/spektroaudio/${_pkg}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname-$pkgver"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ echo "#!/usr/bin/python3" > patchbook
+ cat patchbook.py >> patchbook
+
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # script
+ install -Dm755 patchbook "$pkgdir/usr/bin/patchbook"
+
+ # examples
+ install -d "${pkgdir}/usr/share/doc/${_pkg}"
+ install -Dm644 Examples/* \
+ "$pkgdir/usr/share/doc/${_pkg}/"
+
+ # README
+ install -Dm644 README.md \
+ "$pkgdir/usr/share/doc/${_pkg}/README.md"
+}