summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12023-10-22 00:39:00 +0800
committerChocobo12023-10-22 00:39:00 +0800
commit1bf1218a2e073dbcbd056e86d8770b0752da2f8e (patch)
tree2799b7c8903eee278b9a75c1217961356a68ce8a
downloadaur-1bf1218a2e073dbcbd056e86d8770b0752da2f8e.tar.gz
newpkg: patchelf-git 0.18.0.r12.g917ea45-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD47
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfb05fa29d64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = patchelf-git
+ pkgdesc = A small utility to modify the dynamic linker and RPATH of ELF executables
+ pkgver = 0.18.0.r12.g917ea45
+ pkgrel = 1
+ url = https://github.com/NixOS/patchelf
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = gcc-libs
+ provides = patchelf=0.18.0.r12.g917ea45
+ conflicts = patchelf
+ options = staticlibs
+ source = git+https://github.com/NixOS/patchelf.git
+ sha256sums = SKIP
+
+pkgname = patchelf-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52bff649188c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=patchelf-git
+pkgver=0.18.0.r12.g917ea45
+pkgrel=1
+pkgdesc="A small utility to modify the dynamic linker and RPATH of ELF executables"
+arch=('i686' 'x86_64')
+url="https://github.com/NixOS/patchelf"
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('git')
+provides=("patchelf=$pkgver")
+conflicts=('patchelf')
+options=('staticlibs')
+source=("git+https://github.com/NixOS/patchelf.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "patchelf"
+
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
+}
+
+build() {
+ cd "patchelf"
+
+ ./bootstrap.sh
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "patchelf"
+
+ make check
+}
+
+package() {
+ cd "patchelf"
+
+ make DESTDIR="$pkgdir" install
+}