summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Hu2015-06-30 13:11:56 +0100
committerNick Hu2015-06-30 13:11:56 +0100
commit23dd38636f5451cb17c9717148ffdb994a468d82 (patch)
treed1b037608e2886da2e4d16b78408e4528099fb44
downloadaur-23dd38636f5451cb17c9717148ffdb994a468d82.tar.gz
AUR4 migration
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0112da613fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = patchelfmod
+ pkgdesc = A small utility to modify the dynamic linker and RPATH of ELF executables forked from the original
+ pkgver = 0.16
+ pkgrel = 1
+ url = http://github.com/darealshinji/patchelfmod
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = gcc-libs
+ source = http://github.com/darealshinji/patchelfmod/archive/0.16.tar.gz
+ md5sums = 731f122d43665e321b7578a77da5be0a
+
+pkgname = patchelfmod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cb559bdd0a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nick Hu <me@nickhu.co.uk>
+pkgname=patchelfmod
+pkgver=0.16
+pkgrel=1
+pkgdesc="A small utility to modify the dynamic linker and RPATH of ELF executables forked from the original"
+arch=('i686' 'x86_64')
+url="http://github.com/darealshinji/patchelfmod"
+license=('GPL3')
+depends=('gcc-libs')
+source=(http://github.com/darealshinji/$pkgname/archive/$pkgver.tar.gz)
+md5sums=('731f122d43665e321b7578a77da5be0a')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: