summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordezyh2021-04-17 09:38:48 +0000
committerdezyh2021-04-17 09:38:48 +0000
commit0506d0b77e8c3a96fcf7ef5ef3ce38d1fb10f9ea (patch)
tree76e60a47f5ddfc4c155ab2ec6e1c7d58dce86996
parentde0dfe87192eb9f60d162f0f33af25bc7a410638 (diff)
downloadaur-0506d0b77e8c3a96fcf7ef5ef3ce38d1fb10f9ea.tar.gz
Update PKGBUILD and .SRCINFO with GitHub Actions
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e97540c99787..760cd0bfd50a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = patchup-bin
pkgdesc = A tool to compute and apply binary patches for files and directories
- pkgver = 0.4.0
+ pkgver = 0.1.0
pkgrel = 1
- url = https://github.com/dezyh/patchup/cli
+ url = https://github.com/dezyh/patchup
arch = x86_64
license = MIT
+ makedepends = cargo
provides = patchup
- source = https://github.com/dezyh/patchup/cli/releases/download/v0.4.0/patchup-0.4.0-x86_64.tar.gz
- sha256sums = 193357a14205e8d74df5d691d6f8566e5a0eb70dd1d55d5dab26c70a5405c62a
+ conflicts = patchup
+ source = patchup-0.1.0::https://github.com/dezyh/patchup/releases/download/0.1.0/patchup-cli-bin.tar.gz
+ sha256sums = 34880cc6ed038b52a30992d5878a025cbd4434047ac06ab6b4b5d3eae48235c5
pkgname = patchup-bin
diff --git a/PKGBUILD b/PKGBUILD
index 34ba149151c9..6e6eea6ac1b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,18 @@
# Maintainer: Ben Mitchell <dezyh@outlook.com>
pkgname=patchup-bin
-pkgver=0.4.0
+pkgver=0.1.0
pkgrel=1
pkgdesc="A tool to compute and apply binary patches for files and directories"
-url="https://github.com/dezyh/patchup/cli"
+url="https://github.com/dezyh/patchup"
license=("MIT")
arch=("x86_64")
+makedepends=("cargo")
provides=("patchup")
-source=("https://github.com/dezyh/patchup/cli/releases/download/v$pkgver/patchup-$pkgver-x86_64.tar.gz")
-sha256sums=("193357a14205e8d74df5d691d6f8566e5a0eb70dd1d55d5dab26c70a5405c62a")
+conflicts=("patchup")
+source=("patchup-0.1.0::https://github.com/dezyh/patchup/releases/download/0.1.0/patchup-cli-bin.tar.gz")
+sha256sums=("34880cc6ed038b52a30992d5878a025cbd4434047ac06ab6b4b5d3eae48235c5")
package() {
- install -Dm755 patchup -t "$pkgdir/usr/bin/"
+ cd "patchup-0.1.0"
+ install -Dm755 "patchup" "$pkgdir/usr/bin/patchup"
}