summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordezyh2021-04-15 15:56:01 +0000
committerdezyh2021-04-15 15:56:01 +0000
commitde0dfe87192eb9f60d162f0f33af25bc7a410638 (patch)
treed649fbc3a0dbda323bc1c2f5a88bace795efb581
downloadaur-de0dfe87192eb9f60d162f0f33af25bc7a410638.tar.gz
Update PKGBUILD and .SRCINFO with GitHub Actions
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e97540c99787
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = patchup-bin
+ pkgdesc = A tool to compute and apply binary patches for files and directories
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/dezyh/patchup/cli
+ arch = x86_64
+ license = MIT
+ provides = patchup
+ source = https://github.com/dezyh/patchup/cli/releases/download/v0.4.0/patchup-0.4.0-x86_64.tar.gz
+ sha256sums = 193357a14205e8d74df5d691d6f8566e5a0eb70dd1d55d5dab26c70a5405c62a
+
+pkgname = patchup-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34ba149151c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Ben Mitchell <dezyh@outlook.com>
+pkgname=patchup-bin
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A tool to compute and apply binary patches for files and directories"
+url="https://github.com/dezyh/patchup/cli"
+license=("MIT")
+arch=("x86_64")
+provides=("patchup")
+source=("https://github.com/dezyh/patchup/cli/releases/download/v$pkgver/patchup-$pkgver-x86_64.tar.gz")
+sha256sums=("193357a14205e8d74df5d691d6f8566e5a0eb70dd1d55d5dab26c70a5405c62a")
+
+package() {
+ install -Dm755 patchup -t "$pkgdir/usr/bin/"
+}