summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Careil2021-02-06 15:31:51 +0100
committerBaptiste Careil2021-02-06 15:31:51 +0100
commit70ee3d897ec643dbd345a8000f551ceb63bad700 (patch)
tree7675083774f702042c73dc1952a8262051a34759
parentfdced5e41c4c0e20f7c6b0df9db82e406a728eed (diff)
downloadaur-70ee3d897ec643dbd345a8000f551ceb63bad700.tar.gz
Moved from luajit to lua51 to address out of memory error
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
-rw-r--r--PathOfBuilding-lua51.patch174
-rw-r--r--pobfrontend.patch240
4 files changed, 192 insertions, 254 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1142caeeb38d..94c5ab5955ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = path-of-building-community-git
pkgdesc = An offline build planner for Path of Exile using PoBFrontent, LocalIdentity's fork
- pkgver = 1.4.170.18.r3094.38.481
+ pkgver = 1.4.170.25.r3406.43.513
pkgrel = 1
url = https://github.com/PathOfBuildingCommunity/PathOfBuilding
arch = x86_64
@@ -9,22 +9,25 @@ pkgbase = path-of-building-community-git
makedepends = ninja
makedepends = unzip
makedepends = rsync
+ makedepends = git
depends = zlib
depends = qt5-base
- depends = luajit
+ depends = lua51
+ depends = lua51-bitop
+ depends = lua51-zlib
depends = libgl
depends = curl
depends = ttf-liberation
depends = ttf-bitstream-vera
noextract = PathOfBuilding-runtime-src.zip
source = git+https://github.com/PathOfBuildingCommunity/PathOfBuilding
- source = git+https://github.com/philroberts/pobfrontend
+ source = git+https://gitlab.com/bcareil/pobfrontend.git
source = git+https://github.com/Lua-cURL/Lua-cURLv3
source = https://github.com/Openarl/PathOfBuilding/files/1167199/PathOfBuilding-runtime-src.zip
source = PathOfBuilding.sh
source = lzip-linux.patch
source = PathOfBuilding-force-disable-devmode.patch
- source = pobfrontend.patch
+ source = PathOfBuilding-lua51.patch
source = PathOfBuilding-logo.svg
source = PathOfBuilding-logo.png
source = PathOfBuildingCommunity.desktop
@@ -35,7 +38,7 @@ pkgbase = path-of-building-community-git
sha256sums = f0489b7dd1dcb3f3c22c41e646a5a85d1c7d63d014df6bf1df14fde4361d692d
sha256sums = 9dbc8802b74ceed78f1a6ba1d5b90251f5ae7f9a8cf5497426e4a35001112fcd
sha256sums = 1cca891d3fcb74df7cdf7585c1d96f68b7c3a1cca913589730fcb7e7184888d7
- sha256sums = a46732538c61af4dd47ae65eb7db56d46d9d33d53e9b04451543c027387937cf
+ sha256sums = de8c586f5e69efefe7734f31de17137fc34a06da7428f8f57f640d490b94ea61
sha256sums = 2467d10c7b5e201e337ba334a829e293a07027251bcda2b1f39774a62e8ff194
sha256sums = a64198061f60168ec07df33c37948e343eced7eeafe574cc20bdcf3a1d480cbc
sha256sums = 7e3f2870457dc40b44f6be43791901447c5a5754a77551b5ec92ac3a66fc7ee1
diff --git a/PKGBUILD b/PKGBUILD
index cc4408852cc0..23a049d8e29e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,20 @@ pkgdesc="An offline build planner for Path of Exile using PoBFrontent, LocalIden
arch=('x86_64')
url='https://github.com/PathOfBuildingCommunity/PathOfBuilding'
license=('MIT')
-pkgver=1.4.170.18.r3094.38.481
+pkgver=1.4.170.25.r3406.43.513
-depends=('zlib' 'qt5-base' 'luajit' 'libgl' 'curl' 'ttf-liberation' 'ttf-bitstream-vera')
-makedepends=('meson' 'ninja' 'unzip' 'rsync')
+depends=('zlib' 'qt5-base' 'lua51' 'lua51-bitop' 'lua51-zlib' 'libgl' 'curl' 'ttf-liberation' 'ttf-bitstream-vera')
+makedepends=('meson' 'ninja' 'unzip' 'rsync' 'git')
source=(
'git+https://github.com/PathOfBuildingCommunity/PathOfBuilding'
- 'git+https://github.com/philroberts/pobfrontend'
+ 'git+https://gitlab.com/bcareil/pobfrontend.git'
'git+https://github.com/Lua-cURL/Lua-cURLv3'
'https://github.com/Openarl/PathOfBuilding/files/1167199/PathOfBuilding-runtime-src.zip'
'PathOfBuilding.sh'
'lzip-linux.patch'
'PathOfBuilding-force-disable-devmode.patch'
- 'pobfrontend.patch'
+ 'PathOfBuilding-lua51.patch'
'PathOfBuilding-logo.svg'
'PathOfBuilding-logo.png'
'PathOfBuildingCommunity.desktop'
@@ -32,7 +32,7 @@ sha256sums=(
'f0489b7dd1dcb3f3c22c41e646a5a85d1c7d63d014df6bf1df14fde4361d692d'
'9dbc8802b74ceed78f1a6ba1d5b90251f5ae7f9a8cf5497426e4a35001112fcd'
'1cca891d3fcb74df7cdf7585c1d96f68b7c3a1cca913589730fcb7e7184888d7'
- 'a46732538c61af4dd47ae65eb7db56d46d9d33d53e9b04451543c027387937cf'
+ 'de8c586f5e69efefe7734f31de17137fc34a06da7428f8f57f640d490b94ea61'
'2467d10c7b5e201e337ba334a829e293a07027251bcda2b1f39774a62e8ff194'
'a64198061f60168ec07df33c37948e343eced7eeafe574cc20bdcf3a1d480cbc'
'7e3f2870457dc40b44f6be43791901447c5a5754a77551b5ec92ac3a66fc7ee1'
@@ -50,9 +50,10 @@ prepare() {
# patch lzip
(cd "${srcdir}/PathOfBuilding-runtime-src/LZip" && patch -p1 <"${srcdir}/lzip-linux.patch")
# disable devmode
- (cd "${srcdir}/PathOfBuilding" && patch -p1 <"${srcdir}/PathOfBuilding-force-disable-devmode.patch")
- # fix pobfrontend to have a writable user dir
- (cd "${srcdir}/pobfrontend" && patch -p1 <"${srcdir}/pobfrontend.patch")
+ (cd "${srcdir}/PathOfBuilding" \
+ && patch -p1 <"${srcdir}/PathOfBuilding-force-disable-devmode.patch" \
+ && patch -p1 <"${srcdir}/PathOfBuilding-lua51.patch" \
+ )
}
pkgver() {
diff --git a/PathOfBuilding-lua51.patch b/PathOfBuilding-lua51.patch
new file mode 100644
index 000000000000..7a4eec80f0ea
--- /dev/null
+++ b/PathOfBuilding-lua51.patch
@@ -0,0 +1,174 @@
+diff -ru a/Modules/Common.lua b/Modules/Common.lua
+--- a/Modules/Common.lua 2021-02-06 15:09:21.799784281 +0100
++++ b/Modules/Common.lua 2021-02-06 11:37:28.998539560 +0100
+@@ -3,6 +3,9 @@
+ -- Module: Common
+ -- Libraries, functions and classes used by various modules.
+ --
++
++bit = require("bit")
++
+ local pairs = pairs
+ local ipairs = ipairs
+ local type = type
+diff -ru a/Data/New.lua b/Data/New.lua
+--- a/Data/New.lua 2021-02-06 15:09:21.709829157 +0100
++++ b/Data/New.lua 2021-02-06 11:37:28.858609368 +0100
+@@ -1,3 +1,3 @@
+---
++--
+ -- Upcoming uniques will live here until their mods/rolls are finalised
+ --
+diff -ru a/Data/Uniques/amulet.lua b/Data/Uniques/amulet.lua
+--- a/Data/Uniques/amulet.lua 2021-02-06 15:09:21.776462582 +0100
++++ b/Data/Uniques/amulet.lua 2021-02-06 11:37:28.858609368 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Amulet
+diff -ru a/Data/Uniques/axe.lua b/Data/Uniques/axe.lua
+--- a/Data/Uniques/axe.lua 2021-02-06 15:09:21.776462582 +0100
++++ b/Data/Uniques/axe.lua 2021-02-06 11:37:28.851946025 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Weapon: One Handed Axe
+diff -ru a/Data/Uniques/belt.lua b/Data/Uniques/belt.lua
+--- a/Data/Uniques/belt.lua 2021-02-06 15:09:21.776462582 +0100
++++ b/Data/Uniques/belt.lua 2021-02-06 11:37:28.855277696 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Belt
+diff -ru a/Data/Uniques/body.lua b/Data/Uniques/body.lua
+--- a/Data/Uniques/body.lua 2021-02-06 15:09:21.776462582 +0100
++++ b/Data/Uniques/body.lua 2021-02-06 11:37:28.851946025 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Body: Armour
+diff -ru a/Data/Uniques/boots.lua b/Data/Uniques/boots.lua
+--- a/Data/Uniques/boots.lua 2021-02-06 15:09:21.776462582 +0100
++++ b/Data/Uniques/boots.lua 2021-02-06 11:37:28.851946025 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Boots: Armour
+diff -ru a/Data/Uniques/bow.lua b/Data/Uniques/bow.lua
+--- a/Data/Uniques/bow.lua 2021-02-06 15:09:21.776462582 +0100
++++ b/Data/Uniques/bow.lua 2021-02-06 11:37:28.848614354 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Weapon: Bow
+diff -ru a/Data/Uniques/claw.lua b/Data/Uniques/claw.lua
+--- a/Data/Uniques/claw.lua 2021-02-06 15:09:21.779794253 +0100
++++ b/Data/Uniques/claw.lua 2021-02-06 11:37:28.848614354 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Weapon: Claw
+diff -ru a/Data/Uniques/dagger.lua b/Data/Uniques/dagger.lua
+--- a/Data/Uniques/dagger.lua 2021-02-06 15:09:21.779794253 +0100
++++ b/Data/Uniques/dagger.lua 2021-02-06 11:37:28.848614354 +0100
+@@ -1,4 +1,4 @@
+- -- Item data (c) Grinding Gear Games
++ -- Item data (c) Grinding Gear Games
+
+ return {
+ -- Weapon: Dagger
+diff -ru a/Data/Uniques/flask.lua b/Data/Uniques/flask.lua
+--- a/Data/Uniques/flask.lua 2021-02-06 15:09:21.779794253 +0100
++++ b/Data/Uniques/flask.lua 2021-02-06 11:37:28.855277696 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Flask: Life
+diff -ru a/Data/Uniques/gloves.lua b/Data/Uniques/gloves.lua
+--- a/Data/Uniques/gloves.lua 2021-02-06 15:09:21.779794253 +0100
++++ b/Data/Uniques/gloves.lua 2021-02-06 11:37:28.855277696 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Gloves: Armour
+diff -ru a/Data/Uniques/helmet.lua b/Data/Uniques/helmet.lua
+--- a/Data/Uniques/helmet.lua 2021-02-06 15:09:21.779794253 +0100
++++ b/Data/Uniques/helmet.lua 2021-02-06 11:37:28.855277696 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Helmet: Armour
+diff -ru a/Data/Uniques/mace.lua b/Data/Uniques/mace.lua
+--- a/Data/Uniques/mace.lua 2021-02-06 15:09:21.779794253 +0100
++++ b/Data/Uniques/mace.lua 2021-02-06 11:37:28.848614354 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Weapon: One Handed Mace
+diff -ru a/Data/Uniques/quiver.lua b/Data/Uniques/quiver.lua
+--- a/Data/Uniques/quiver.lua 2021-02-06 15:09:21.779794253 +0100
++++ b/Data/Uniques/quiver.lua 2021-02-06 11:37:28.848614354 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Quiver
+diff -ru a/Data/Uniques/ring.lua b/Data/Uniques/ring.lua
+--- a/Data/Uniques/ring.lua 2021-02-06 15:09:21.779794253 +0100
++++ b/Data/Uniques/ring.lua 2021-02-06 11:37:28.845282683 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Ring
+diff -ru a/Data/Uniques/shield.lua b/Data/Uniques/shield.lua
+--- a/Data/Uniques/shield.lua 2021-02-06 15:09:21.779794253 +0100
++++ b/Data/Uniques/shield.lua 2021-02-06 11:37:28.845282683 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Shield: Armour
+diff -ru a/Data/Uniques/staff.lua b/Data/Uniques/staff.lua
+--- a/Data/Uniques/staff.lua 2021-02-06 15:09:21.779794253 +0100
++++ b/Data/Uniques/staff.lua 2021-02-06 11:37:28.851946025 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Weapon: Staff
+diff -ru a/Data/Uniques/wand.lua b/Data/Uniques/wand.lua
+--- a/Data/Uniques/wand.lua 2021-02-06 15:09:21.779794253 +0100
++++ b/Data/Uniques/wand.lua 2021-02-06 11:37:28.858609368 +0100
+@@ -1,4 +1,4 @@
+--- Item data (c) Grinding Gear Games
++-- Item data (c) Grinding Gear Games
+
+ return {
+ -- Weapon: Wand
diff --git a/pobfrontend.patch b/pobfrontend.patch
deleted file mode 100644
index 9e3b400dc5b9..000000000000
--- a/pobfrontend.patch
+++ /dev/null
@@ -1,240 +0,0 @@
-diff --git a/main.cpp b/main.cpp
-index 69accac..c33c19c 100644
---- a/main.cpp
-+++ b/main.cpp
-@@ -525,7 +525,7 @@ static int l_imgHandleIsValid(lua_State* L)
-
- static int l_imgHandleIsLoading(lua_State* L)
- {
-- imgHandle_s* imgHandle = GetImgHandle(L, "IsLoading", true);
-+// imgHandle_s* imgHandle = GetImgHandle(L, "IsLoading", true);
- // int width, height;
- // pobwindow->renderer->GetShaderImageSize(imgHandle->hnd, width, height);
- lua_pushboolean(L, false);
-@@ -534,7 +534,7 @@ static int l_imgHandleIsLoading(lua_State* L)
-
- static int l_imgHandleSetLoadingPriority(lua_State* L)
- {
-- imgHandle_s* imgHandle = GetImgHandle(L, "SetLoadingPriority", true);
-+// imgHandle_s* imgHandle = GetImgHandle(L, "SetLoadingPriority", true);
- int n = lua_gettop(L);
- pobwindow->LAssert(L, n >= 1, "Usage: imgHandle:SetLoadingPriority(pri)");
- pobwindow->LAssert(L, lua_isnumber(L, 1), "imgHandle:SetLoadingPriority() argument 1: expected number, got %t", 1);
-@@ -746,8 +746,8 @@ static int l_DrawImageQuad(lua_State* L)
-
- DrawStringCmd::DrawStringCmd(float X, float Y, int Align, int Size, int Font, const char *Text) : text(Text) {
- dscount++;
-- if (text.size() >= 2 && text[0] == '^') {
-- switch(text[1].toLatin1()) {
-+ if (Text[0] == '^' && Text[1] != '\0') {
-+ switch(Text[1]) {
- case '0':
- setCol(0.0f, 0.0f, 0.0f);
- break;
-@@ -1446,7 +1446,7 @@ static int l_ConPrintf(lua_State* L)
- lua_insert(L, 1);
- lua_call(L, n, 1);
- pobwindow->LAssert(L, lua_isstring(L, 1), "ConPrintf() error: string.format returned non-string");
-- //std::cout << lua_tostring(L, 1) << std::endl;
-+ std::cout << lua_tostring(L, 1) << std::endl;
- //pobwindow->sys->con->Printf("%s\n", lua_tostring(L, 1));
- return 0;
- }
-@@ -1595,6 +1595,7 @@ static int l_Exit(lua_State* L)
- pobwindow->LAssert(L, lua_isstring(L, 1), "Exit() argument 1: expected string or nil, got %t", 1);
- msg = lua_tostring(L, 1);
- }
-+ (void)msg;
- // FIXME
- //pobwindow->sys->Exit(msg);
- //pobwindow->didExit = true;
-@@ -1606,6 +1607,52 @@ static int l_Exit(lua_State* L)
- #define ADDFUNC(n) lua_pushcclosure(L, l_##n, 0);lua_setglobal(L, #n);
- #define ADDFUNCCL(n, u) lua_pushcclosure(L, l_##n, u);lua_setglobal(L, #n);
-
-+void RegisterGeneralLuaCallbacks(lua_State* L)
-+{
-+ // General function
-+ ADDFUNC(SetWindowTitle);
-+ ADDFUNC(GetCursorPos);
-+ ADDFUNC(SetCursorPos);
-+ ADDFUNC(ShowCursor);
-+ ADDFUNC(IsKeyDown);
-+ ADDFUNC(Copy);
-+ ADDFUNC(Paste);
-+ ADDFUNC(Deflate);
-+ ADDFUNC(Inflate);
-+ ADDFUNC(GetTime);
-+ ADDFUNC(GetScriptPath);
-+ ADDFUNC(GetRuntimePath);
-+ ADDFUNC(GetUserPath);
-+ ADDFUNC(MakeDir);
-+ ADDFUNC(RemoveDir);
-+ ADDFUNC(SetWorkDir);
-+ ADDFUNC(GetWorkDir);
-+ ADDFUNC(LaunchSubScript);
-+ ADDFUNC(AbortSubScript);
-+ ADDFUNC(IsSubScriptRunning);
-+ ADDFUNC(LoadModule);
-+ ADDFUNC(PLoadModule);
-+ ADDFUNC(PCall);
-+ lua_getglobal(L, "string");
-+ lua_getfield(L, -1, "format");
-+ ADDFUNCCL(ConPrintf, 1);
-+ lua_pop(L, 1); // Pop 'string' table
-+ ADDFUNC(ConPrintTable);
-+ ADDFUNC(ConExecute);
-+ ADDFUNC(ConClear);
-+ ADDFUNC(print);
-+ ADDFUNC(SpawnProcess);
-+ ADDFUNC(OpenURL);
-+ ADDFUNC(SetProfiling);
-+ ADDFUNC(Restart);
-+ ADDFUNC(Exit);
-+ lua_getglobal(L, "os");
-+ lua_pushcfunction(L, l_Exit);
-+ lua_setfield(L, -2, "exit");
-+ lua_pop(L, 1); // Pop 'os' table
-+
-+}
-+
- int main(int argc, char **argv)
- {
- QGuiApplication app{argc, argv};
-@@ -1691,47 +1738,7 @@ int main(int argc, char **argv)
- lua_setfield(L, -2, "GetFileModifiedTime");
- lua_setfield(L, LUA_REGISTRYINDEX, "uisearchhandlemeta");
-
-- // General function
-- ADDFUNC(SetWindowTitle);
-- ADDFUNC(GetCursorPos);
-- ADDFUNC(SetCursorPos);
-- ADDFUNC(ShowCursor);
-- ADDFUNC(IsKeyDown);
-- ADDFUNC(Copy);
-- ADDFUNC(Paste);
-- ADDFUNC(Deflate);
-- ADDFUNC(Inflate);
-- ADDFUNC(GetTime);
-- ADDFUNC(GetScriptPath);
-- ADDFUNC(GetRuntimePath);
-- ADDFUNC(GetUserPath);
-- ADDFUNC(MakeDir);
-- ADDFUNC(RemoveDir);
-- ADDFUNC(SetWorkDir);
-- ADDFUNC(GetWorkDir);
-- ADDFUNC(LaunchSubScript);
-- ADDFUNC(AbortSubScript);
-- ADDFUNC(IsSubScriptRunning);
-- ADDFUNC(LoadModule);
-- ADDFUNC(PLoadModule);
-- ADDFUNC(PCall);
-- lua_getglobal(L, "string");
-- lua_getfield(L, -1, "format");
-- ADDFUNCCL(ConPrintf, 1);
-- lua_pop(L, 1); // Pop 'string' table
-- ADDFUNC(ConPrintTable);
-- ADDFUNC(ConExecute);
-- ADDFUNC(ConClear);
-- ADDFUNC(print);
-- ADDFUNC(SpawnProcess);
-- ADDFUNC(OpenURL);
-- ADDFUNC(SetProfiling);
-- ADDFUNC(Restart);
-- ADDFUNC(Exit);
-- lua_getglobal(L, "os");
-- lua_pushcfunction(L, l_Exit);
-- lua_setfield(L, -2, "exit");
-- lua_pop(L, 1); // Pop 'os' table
-+ RegisterGeneralLuaCallbacks(L);
-
- int result = luaL_dofile(L, "Launch.lua");
- if (result != 0) {
-diff --git a/main.h b/main.h
-index 224a15a..93b40d1 100644
---- a/main.h
-+++ b/main.h
-@@ -34,6 +34,7 @@ enum r_texFlag_e {
-
- class Cmd {
- public:
-+ virtual ~Cmd() = default;
- virtual void execute() = 0;
- };
-
-diff --git a/meson.build b/meson.build
-index 871cdc3..045b094 100644
---- a/meson.build
-+++ b/meson.build
-@@ -16,6 +16,12 @@ zlib_dep = dependency('zlib')
- qt5 = import('qt5')
- prep = qt5.preprocess(moc_headers : ['subscript.hpp', 'pobwindow.hpp'])
-
-+extra_args = []
-+if meson.get_compiler('cpp').get_id() == 'gcc'
-+ extra_args = ['-Wno-reorder']
-+endif
-+
- executable('pobfrontend',
- sources : ['main.cpp', prep],
-- dependencies : [qt5_dep, gl_dep, zlib_dep, lua_dep])
-+ dependencies : [qt5_dep, gl_dep, zlib_dep, lua_dep],
-+ cpp_args: extra_args)
-diff --git a/pobwindow.hpp b/pobwindow.hpp
-index cd88f54..7edec7f 100644
---- a/pobwindow.hpp
-+++ b/pobwindow.hpp
-@@ -2,6 +2,7 @@
- #include <QDir>
- #include <QOpenGLWindow>
- #include <QPainter>
-+#include <QStandardPaths>
- #include <memory>
-
- #include "main.h"
-@@ -30,10 +31,11 @@ public:
- // theformat.setAlphaBufferSize(8);
- // std::cout << theformat.hasAlpha() << std::endl;
- // setFormat(theformat);
-+ QString AppDataLocation = QStandardPaths::writableLocation(QStandardPaths::AppDataLocation);
- scriptPath = QDir::currentPath();
- scriptWorkDir = QDir::currentPath();
- basePath = QDir::currentPath();
-- userPath = QDir::currentPath();
-+ userPath = AppDataLocation;
-
- fontFudge = 0;
- }
-diff --git a/subscript.hpp b/subscript.hpp
-index defc016..6dae331 100644
---- a/subscript.hpp
-+++ b/subscript.hpp
-@@ -12,10 +12,12 @@ extern "C" {
- #include "luajit.h"
- }
-
--static int dummy_ConPrintf(lua_State* L)
--{
-- return 0;
--}
-+void RegisterGeneralLuaCallbacks(lua_State* L);
-+
-+//static int dummy_ConPrintf(lua_State* L)
-+//{
-+// return 0;
-+//}
-
- class SubScript : public QThread {
- Q_OBJECT
-@@ -26,8 +28,9 @@ public:
- lua_pushlightuserdata(L, this);
- lua_rawseti(L, LUA_REGISTRYINDEX, 0);
- luaL_openlibs(L);
-- lua_pushcfunction(L, dummy_ConPrintf);
-- lua_setglobal(L, "ConPrintf");
-+ //lua_pushcfunction(L, dummy_ConPrintf);
-+ //lua_setglobal(L, "ConPrintf");
-+ RegisterGeneralLuaCallbacks(L);
- int err = luaL_loadstring(L, lua_tostring(L_main, 1));
- if (err) {
- std::cout << "Error in subscript: " << err << std::endl;