summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÁdler Neves2019-05-21 15:55:36 -0300
committerÁdler Neves2019-05-21 15:55:36 -0300
commit9388bf5077aad4727d389d4d903e41a656f4677b (patch)
treec64ccc8ca0267df697d1e2af655ef49817af843d
parentf408bce29b8e0afbadad1cc4bfad20510e54df4a (diff)
downloadaur-9388bf5077aad4727d389d4d903e41a656f4677b.tar.gz
Version updated
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD10
-rwxr-xr-xmkPKGBUILD.py25
4 files changed, 32 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c30fa533e08..eb377b11cedc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pathio-alpha-bin
pkgdesc = A modern slicer for extrusion 3D printing provided by E3D Skunkworks (binary AppImage).
- pkgver = 0.5.4_1
+ pkgver = 0.5.5_0
pkgrel = 0
url = https://pathio.xyz/
arch = x86_64
@@ -9,10 +9,10 @@ pkgbase = pathio-alpha-bin
provides = pathio
conflicts = pathio
options = !strip
- source = pathio-0.5.4_1-alpha.AppImage::https://api.pathio.xyz/api/asset/download/76
+ source = pathio-alpha-v0.5.5-alpha0.AppImage::https://api.pathio.xyz/api/asset/download/79
source = license.html::https://docs.pathio.xyz/pathio/latest/legal/termsAndConditions.html
source = pathio.sh
- sha512sums = fd02ae261279ec11c8147a27fa322564f9c44940d7fc105ae4770f8c7bcb9ea75e7b910c41aeba578a3b3baebd5be164ad8cfbfad6294be50735da52a10a68fc
+ sha512sums = 51257d7591aa5520df6771f2c80129774c7b36521fe77e20d6ca93378693a0f2dffa0fe102ee699398767d17996c26c3230703d816283de149ed932293388c02
sha512sums = 355bbabd3dfed0816aebe12c10efa2743ab588a2b7d5ad7543da7a11d4ce4b5e6e591d2a80d153ac3715f044e71dd1e9695e20c5a10e1d9c45b1fdc6bc4a21bc
sha512sums = 7cee7ed780dbe2f0a7e7221836bc40da0d5e295a40e2689ffc6f9da0fc11a9edfba12dd3d8214cd5f1bed30fe9755cb4742f7c36d12573e6a9f97b39c0b69981
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7ff3449bcd6b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.xz
+*.AppImage
+license.html
+pkg/**
+src/**
diff --git a/PKGBUILD b/PKGBUILD
index 68e2a7906c9e..88884231d0f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,22 @@
provides=('pathio')
conflicts=('pathio')
_channel=alpha
-pkgver=0.5.4_1
+pkgver=0.5.5_0
pkgname=pathio-alpha-bin
pkgrel=0
+_upstream_version=0.5.5
+_upstream_channel=alpha
pkgdesc="A modern slicer for extrusion 3D printing provided by E3D Skunkworks (binary AppImage)."
arch=('x86_64')
makedepends=('elinks')
url="https://pathio.xyz/"
options=('!strip')
license=('custom:Pathio Software License Agreement')
-_filename="pathio-$pkgver-$_channel.AppImage"
-source=("$_filename::https://api.pathio.xyz/api/asset/download/76"
+_filename="pathio-$_channel-v$_upstream_version-$_upstream_channel$pkgrel.AppImage"
+source=("$_filename::https://api.pathio.xyz/api/asset/download/79"
license.html::https://docs.pathio.xyz/pathio/latest/legal/termsAndConditions.html
pathio.sh)
-sha512sums=('fd02ae261279ec11c8147a27fa322564f9c44940d7fc105ae4770f8c7bcb9ea75e7b910c41aeba578a3b3baebd5be164ad8cfbfad6294be50735da52a10a68fc'
+sha512sums=('51257d7591aa5520df6771f2c80129774c7b36521fe77e20d6ca93378693a0f2dffa0fe102ee699398767d17996c26c3230703d816283de149ed932293388c02'
'355bbabd3dfed0816aebe12c10efa2743ab588a2b7d5ad7543da7a11d4ce4b5e6e591d2a80d153ac3715f044e71dd1e9695e20c5a10e1d9c45b1fdc6bc4a21bc'
'7cee7ed780dbe2f0a7e7221836bc40da0d5e295a40e2689ffc6f9da0fc11a9edfba12dd3d8214cd5f1bed30fe9755cb4742f7c36d12573e6a9f97b39c0b69981')
diff --git a/mkPKGBUILD.py b/mkPKGBUILD.py
index 6a41002c9236..98eac6865913 100755
--- a/mkPKGBUILD.py
+++ b/mkPKGBUILD.py
@@ -17,13 +17,15 @@ _channel={0}
pkgver={1}
pkgname={2}
pkgrel={3}
+_upstream_version={5}
+_upstream_channel={6}
pkgdesc="A modern slicer for extrusion 3D printing provided by E3D Skunkworks (binary AppImage)."
arch=('x86_64')
makedepends=('elinks')
url="https://pathio.xyz/"
options=('!strip')
license=('custom:Pathio Software License Agreement')
-_filename="pathio-$pkgver-$_channel.AppImage"
+_filename="pathio-$_channel-v$_upstream_version-$_upstream_channel$pkgrel.AppImage"
source=("$_filename::{4}"
license.html::https://docs.pathio.xyz/pathio/latest/legal/termsAndConditions.html
pathio.sh)
@@ -77,17 +79,25 @@ package() {
def render_pkgbuild(branch, release):
- version = (
+ version2 = (
release['version_major'],
release['version_minor'],
release['version_patch'],
BRANCHES.index(release['version_channel_name'])
)
- version = f"{version[0]}.{version[1]}.{version[2]}_{version[3]}"
+ version = f"{version2[0]}.{version2[1]}.{version2[2]}_{version2[3]}"
patch = release['version_channel_edition']
url = release['download_url']
pkgname = 'pathio-bin' if branch == 'stable' else f"pathio-{branch}-bin"
- return PKGBUILD_TEMPLATE.format(branch, version, pkgname, patch, url)+PKGBUILD_STATIC_PART
+ return PKGBUILD_TEMPLATE.format(
+ branch,
+ version,
+ pkgname,
+ patch,
+ url,
+ '.'.join(list(map(str, version2[:-1]))),
+ BRANCHES[version2[3]]
+ )+PKGBUILD_STATIC_PART
def main():
@@ -109,13 +119,14 @@ def main():
)
subprocess.run("rm -f license.html", shell=True)
subprocess.run("updpkgsums", shell=True).check_returncode()
- subprocess.run("makepkg --printsrcinfo > .SRCINFO", shell=True).check_returncode()
+ subprocess.run("makepkg --printsrcinfo > .SRCINFO",
+ shell=True).check_returncode()
subprocess.run("rm -f license.html", shell=True)
subprocess.run("makepkg -f", shell=True).check_returncode()
- subprocess.run('git commit -am "Version updated"', shell=True).check_returncode()
+ subprocess.run('git commit -am "Version updated"',
+ shell=True).check_returncode()
print('Now, double-check everything and "git push"')
-
if __name__ == '__main__':
main()