summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpatlefort2023-11-23 18:00:02 +0100
committerNarrat2023-11-23 18:00:02 +0100
commit9eee632dca6073d4badc7e8a9557c03495fac7e1 (patch)
treec43b31a5fa5f5086eb9388c4955f69550c0d01eb
parent16af0dcf2731ce85d6d0f232043d3312ae7fff4b (diff)
downloadaur-9eee632dca6073d4badc7e8a9557c03495fac7e1.tar.gz
patool: add bash_completion and man-page
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b7b0bf050d3..4311daadca4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = patool
pkgdesc = portable command line archive file manager
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://wummel.github.io/patool/
arch = any
license = GPL
@@ -9,6 +9,7 @@ pkgbase = patool
makedepends = python-installer
makedepends = python-wheel
makedepends = python-setuptools
+ makedepends = python-argcomplete
depends = python
optdepends = lz4: extracting LZ4 archives
optdepends = p7zip: extracting ZIP and 7z files
diff --git a/PKGBUILD b/PKGBUILD
index dc7ae9f18c62..0b648e326692 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Lex Black <autumn-wind at web dot de>
+# Contributor: patlefort <northon_patrick3 at yahoo dot ca>
# Contributor: Daniel Larsson <znixen@live.se>
pkgbase=patool
pkgname='patool'
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="portable command line archive file manager"
arch=('any')
url="https://wummel.github.io/patool/"
license=('GPL')
depends=('python')
-makedepends=(python-build python-installer python-wheel python-setuptools)
+makedepends=(python-build python-installer python-wheel python-setuptools python-argcomplete)
optdepends=("lz4: extracting LZ4 archives"
"p7zip: extracting ZIP and 7z files"
"unarchiver: extracting various formats"
@@ -29,4 +30,9 @@ build() {
package() {
cd "${pkgbase}-upstream-${pkgver}"
python -m installer --destdir="$pkgdir" dist/*.whl
+
+ install -dm755 "${pkgdir}/usr/share/bash-completion/completions"
+ register-python-argcomplete patool > "${pkgdir}/usr/share/bash-completion/completions/patool"
+
+ install -Dm644 'doc/patool.1' -t "${pkgdir}/usr/share/man/man1"
}