summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2023-10-27 18:13:15 +0200
committerNarrat2023-10-27 18:13:15 +0200
commitfa853a14b887f2c40e150542a50e6cbee3c35a3f (patch)
tree660961e9b66e88a724beaf5d061d58e94d8b6b47
parentad4b5be632aade31d371c1199bbe50a4888f9dd4 (diff)
downloadaur-fa853a14b887f2c40e150542a50e6cbee3c35a3f.tar.gz
patool: update to 1.14.1
and make zstd an obvious optdepends
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 364c12dbe52a..d0888b0229e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = patool
pkgdesc = portable command line archive file manager
- pkgver = 1.12
- pkgrel = 5
+ pkgver = 1.14.1
+ pkgrel = 1
url = https://wummel.github.io/patool/
arch = any
license = GPL
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
optdepends = tar: extracting TAR files
optdepends = unrar: extracting RAR files
optdepends = p7zip: extracting ZIP and 7z files
- source = patool-1.12.tar.gz::https://github.com/wummel/patool/archive/upstream/1.12.tar.gz
- sha256sums = 582fd4b87c263325958c1550400504799018c88bc3444f249bba304ae1747f1f
+ optdepends = zstd: extracting ZSTANDARD files
+ source = patool-1.14.1.tar.gz::https://github.com/wummel/patool/archive/upstream/1.14.1.tar.gz
+ sha256sums = 51b2abdd4ccd9eb93884e61fc401295d8990b30c8c98d70c24bb835a21ec27e0
pkgname = patool
diff --git a/PKGBUILD b/PKGBUILD
index fa3e6aecd404..db4e9fbe9be0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,29 @@
pkgbase=patool
pkgname='patool'
-pkgver=1.12
-pkgrel=5
+pkgver=1.14.1
+pkgrel=1
pkgdesc="portable command line archive file manager"
arch=('any')
url="https://wummel.github.io/patool/"
license=('GPL')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=(python-build python-installer python-wheel)
optdepends=("tar: extracting TAR files"
"unrar: extracting RAR files"
- "p7zip: extracting ZIP and 7z files")
+ "p7zip: extracting ZIP and 7z files"
+ "zstd: extracting ZSTANDARD files")
#source=("https://pypi.python.org/packages/source/p/$pkgbase/$pkgbase-$pkgver.tar.gz")
source=("$pkgbase-$pkgver.tar.gz::https://github.com/wummel/patool/archive/upstream/${pkgver}.tar.gz")
-sha256sums=('582fd4b87c263325958c1550400504799018c88bc3444f249bba304ae1747f1f')
+sha256sums=('51b2abdd4ccd9eb93884e61fc401295d8990b30c8c98d70c24bb835a21ec27e0')
build() {
cd "${pkgbase}-upstream-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${pkgbase}-upstream-${pkgver}"
- python setup.py install --root=$pkgdir --prefix=/usr --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}