summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2024-04-18 00:54:23 +0200
committerPeter Mattern2024-04-18 00:54:23 +0200
commit21a95f7fc0b3d7ab4c7326d89470ff155024f035 (patch)
tree5324c48a9bf09ebabedf28e745c20bf77d1cedb0
parent65f9609b772e626b35de36fa26f884db26bcdcdc (diff)
downloadaur-21a95f7fc0b3d7ab4c7326d89470ff155024f035.tar.gz
Miscellaneous updates
* update upstream URL * use SPDX license string * update dependencies to build against Qt 6 * improve pkgver()
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c94f938c52b..23b4ef823fa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
-# Generated by mksrcinfo v8
-# Sun Aug 13 23:16:11 UTC 2017
pkgbase = pavucontrol-qt-git
pkgdesc = Qt port of pavucontrol
- pkgver = 0.2.0.20.g3d26e86
+ pkgver = 2.0.0
pkgrel = 1
- url = https://github.com/lxde/pavucontrol-qt
+ url = https://github.com/lxqt/pavucontrol-qt
arch = i686
arch = x86_64
- license = GPL2
+ license = GPL-2.0-only
makedepends = git
makedepends = cmake
- makedepends = qt5-tools
+ makedepends = qt6-tools
makedepends = lxqt-build-tools-git
depends = libpulse
- depends = qt5-base
+ depends = qt6-base
provides = pavucontrol-qt
conflicts = pavucontrol-qt
- source = git+https://github.com/lxde/pavucontrol-qt.git
+ source = git+https://github.com/lxqt/pavucontrol-qt.git
sha256sums = SKIP
pkgname = pavucontrol-qt-git
-
diff --git a/PKGBUILD b/PKGBUILD
index db7f3cc006bd..95406a474f43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,28 @@
_pkgname='pavucontrol-qt'
pkgname="$_pkgname-git"
-pkgver=0.2.0.20.g3d26e86
+pkgver=2.0.0
pkgrel=1
pkgdesc='Qt port of pavucontrol'
arch=('i686' 'x86_64')
-url="https://github.com/lxde/$_pkgname"
-license=('GPL2')
-depends=('libpulse' 'qt5-base')
-makedepends=('git' 'cmake' 'qt5-tools' 'lxqt-build-tools-git')
+url="https://github.com/lxqt/$_pkgname"
+license=('GPL-2.0-only')
+depends=('libpulse' 'qt6-base')
+makedepends=('git' 'cmake' 'qt6-tools' 'lxqt-build-tools-git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://github.com/lxde/$_pkgname.git")
+source=("git+${url}.git")
sha256sums=("SKIP")
pkgver() {
cd $_pkgname
- git describe --always | sed "s/-/./g"
+ git describe --always | sed "s/-/.r/;s/-/./"
}
build() {
rm -Rf build ; mkdir build ; cd build
cmake $srcdir/$_pkgname \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr
make
}