summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Heusel2023-03-28 21:20:53 +0200
committerChristian Heusel2023-03-28 21:20:53 +0200
commit596fd37b484093186ecd86f4a3688e8c374ae716 (patch)
tree16ed056cf5bba993258604a7f7b63e9ee2b55148
parent1b17fadeaf45f353aa4a7c3cdedcd10170a07a6b (diff)
downloadaur-596fd37b484093186ecd86f4a3688e8c374ae716.tar.gz
improve the pawxel-git package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82e0cec40773..c0aa6cd071b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pawxel-git
pkgdesc = Lightweight screenshot tool for designers & developers
- pkgver = 0.1.2.r18.gc7cabfb
+ pkgver = 0.1.2.r24.ge71c769
pkgrel = 1
url = https://pawxel.rocks/
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = pawxel-git
depends = glib2
provides = pawxel
conflicts = pawxel
- source = pawxel-git::git+https://github.com/yeahitsjan/pawxel.git
+ source = git+https://github.com/yeahitsjan/pawxel.git
sha256sums = SKIP
pkgname = pawxel-git
diff --git a/PKGBUILD b/PKGBUILD
index dfe0d85ffbe6..9e34af8674ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Christian Heusel <christian@heusel.eu>
pkgname=pawxel-git
-pkgver=0.1.2.r18.gc7cabfb
+_pkgname=${pkgname%-git}
+pkgver=0.1.2.r24.ge71c769
pkgrel=1
-pkgdesc='Lightweight screenshot tool for designers & developers '
+pkgdesc='Lightweight screenshot tool for designers & developers'
arch=('x86_64')
url='https://pawxel.rocks/'
license=('GPL3')
@@ -11,28 +12,28 @@ makedepends=('git')
depends=('qt5-base' 'qt5-x11extras' 'gtk3' 'libxcb' 'libx11' 'glib2')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("$pkgname::git+https://github.com/yeahitsjan/${pkgname%-git}.git")
+source=("git+https://github.com/yeahitsjan/$_pkgname.git")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_pkgname"
git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$pkgname"
+ cd "$_pkgname"
git submodule update --init
}
build() {
- cd "$pkgname"
+ cd "$_pkgname"
qmake
make
}
package() {
- cd "$pkgname"
- install -Dm755 ${pkgname%-git} $pkgdir/usr/bin/${pkgname%-git}
+ cd "$_pkgname"
+ install -Dm755 $_pkgname $pkgdir/usr/bin/$_pkgname
}