summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhuantian2021-07-04 12:36:50 -0700
committerhuantian2021-07-04 12:36:50 -0700
commit6491faa5a6b24024ef4f62ac06efd3cd4a57104e (patch)
tree7550db0c4e1430e49c4b0ca535dfc44a3f52106f
downloadaur-6491faa5a6b24024ef4f62ac06efd3cd4a57104e.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88f9ef5bfd8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pax-mc-git
+ pkgdesc = The MC modpack manager for professionals. VSC version.
+ pkgver = 1.6.0.r0.g42bdf30
+ pkgrel = 1
+ url = https://github.com/froehlicha/pax
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = nim
+ makedepends = nimble
+ provides = pax-mc
+ conflicts = pax-mc-bin
+ conflicts = pax-mc
+ source = git+https://github.com/froehlichA/pax.git
+ sha256sums = SKIP
+
+pkgname = pax-mc-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5da87cce5d19
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+.directory
+pkg
+src
+pax*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ec85073d884
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: David Li <davidtianli@gmail.com>
+pkgname=pax-mc-git
+pkgver=1.6.0.r0.g42bdf30
+pkgrel=1
+pkgdesc="The MC modpack manager for professionals. VSC version."
+arch=('x86_64')
+url="https://github.com/froehlicha/pax"
+license=('MIT')
+makedepends=('git' 'nim' 'nimble')
+provides=('pax-mc')
+conflicts=('pax-mc-bin' 'pax-mc')
+replaces=()
+changelog=
+source=("git+https://github.com/froehlichA/pax.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/pax"
+ echo "y" | nimble build --nimbleDir:"${srcdir}/nimble" -d:ssl
+}
+
+package() {
+ install -d -m755 "${pkgdir}/usr/bin"
+ install -m755 "${srcdir}/pax/pax" "${pkgdir}/usr/bin/pax"
+}