summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoriff2024-12-10 20:04:46 +0100
committeriff2024-12-10 20:07:42 +0100
commit2f6b3d60438cc5ad00b87fac66a5b4c5d9537f2d (patch)
tree3e91c09103b40b513855dedf18c0955cca21fa18
parente2ea0945e16c97e1288da3b70f907afce785856e (diff)
downloadaur-2f6b3d60438cc5ad00b87fac66a5b4c5d9537f2d.tar.gz
v0.6.3
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
-rw-r--r--pay-respects.install16
-rwxr-xr-xpay-respects.sh5
5 files changed, 57 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b77438ccaa6d..4d76d2cefb95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,22 @@
pkgbase = pay-respects
pkgdesc = Command suggestions, command-not-found and thefuck replacement written in Rust (All modules)
- pkgver = 0.6.2
+ pkgver = 0.6.3
pkgrel = 1
url = https://github.com/iffse/pay-respects
+ install = pay-respects.install
arch = x86_64
- license = AGPL
+ arch = aarch64
+ arch = armv7h
+ arch = i686
+ license = AGPL-3.0-or-later
makedepends = cargo
makedepends = git
- optdepends = curl: for AI suggestions
- source = pay-respects::git+https://github.com/iffse/pay-respects#tag=v0.6.2
- sha1sums = 3078dce1e41fb4455c62523fdb0e60b90214ded7
+ makedepends = openssl
+ optdepends = curl: AI requests
+ provides = pay-respects
+ source = pay-respects::git+https://github.com/iffse/pay-respects#tag=v0.6.3
+ source = pay-respects.sh
+ sha1sums = 22fbf46fcc7815d97d39bbf304200b8a5f30667f
+ sha1sums = 4c8399cfcd8e943800430f7c249f971e464fdaae
pkgname = pay-respects
diff --git a/.gitignore b/.gitignore
index bfcf37c13114..26ecf23534dd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,4 @@
-pay-respects*
+pay-respects/*
+pay-respects-*
+pkg
src
diff --git a/PKGBUILD b/PKGBUILD
index ea0b913b47f9..09ece3230e53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: iff <iff@ik.me>
pkgname="pay-respects"
-pkgver=0.6.2
+pkgver=0.6.3
pkgrel=1
pkgdesc="Command suggestions, command-not-found and thefuck replacement written in Rust (All modules)"
-arch=("x86_64")
+arch=('x86_64' 'aarch64' 'armv7h' 'i686')
url="https://github.com/iffse/pay-respects"
-license=('AGPL')
-makedepends=('cargo' 'git')
+license=('AGPL-3.0-or-later ')
+provides=('pay-respects')
+install="$pkgname.install"
+makedepends=('cargo' 'git' 'openssl')
optdepends=(
- 'curl: for AI suggestions'
+ 'curl: AI requests'
)
-source=("$pkgname::git+https://github.com/iffse/pay-respects#tag=v$pkgver")
-sha1sums=('3078dce1e41fb4455c62523fdb0e60b90214ded7')
+source=($pkgname::git+https://github.com/iffse/pay-respects#tag=v$pkgver
+ ${pkgname}.sh
+)
+
+sha1sums=('22fbf46fcc7815d97d39bbf304200b8a5f30667f'
+ '4c8399cfcd8e943800430f7c249f971e464fdaae')
prepare() {
cd "$pkgname"
@@ -23,12 +29,16 @@ build() {
cd "$pkgname"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
+ export _PR_LIB=/usr/libexec/pay-respects
cargo build --frozen --release --all-features
}
package() {
+ install -Dm755 "${pkgname}.sh" "$pkgdir/usr/bin/${pkgname}"
cd "$pkgname"
- install -Dm755 "target/release/pay-respects" "$pkgdir/usr/bin/pay-respects"
- install -Dm755 "target/release/_pay-respects-module-100-runtime-rules" "$pkgdir/usr/bin/_pay-respects-module-100-runtime-rules"
- install -Dm755 "target/release/_pay-respects-fallback-100-request-ai" "$pkgdir/usr/bin/_pay-respects-fallback-100-request-ai"
+ install -Dm755 "target/release/pay-respects" "$pkgdir/opt/pay-respects/bin/pay-respects"
+ install -Dm755 "target/release/_pay-respects-module-100-runtime-rules" "$pkgdir/usr/libexec/pay-respects/_pay-respects-module-100-runtime-rules"
+ install -Dm755 "target/release/_pay-respects-fallback-100-request-ai" "$pkgdir/usr/libexec/pay-respects/_pay-respects-fallback-100-request-ai"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/pay-respects.install b/pay-respects.install
new file mode 100644
index 000000000000..bad29661b17e
--- /dev/null
+++ b/pay-respects.install
@@ -0,0 +1,16 @@
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "Custom modules should be placed in: ~/.local/libexec/pay-respects/"
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/pay-respects.sh b/pay-respects.sh
new file mode 100755
index 000000000000..11b3ba83b325
--- /dev/null
+++ b/pay-respects.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+if [ "$#" -gt 1 ]; then
+ echo "_PR_LIB=/usr/libexec/pay-respects:$HOME/.local/libexec/pay-respects"
+fi
+/opt/pay-respects/bin/pay-respects "$@"