summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZack Buhman2015-10-07 20:55:17 -0500
committerZack Buhman2015-10-07 20:55:17 -0500
commitdf9ffc7c29073059801e0a82331c0d4b5193da3e (patch)
treee0fac2867794088cf17abdb626de2b6c491530cb
parent7f17883e9ac8160039768d83daced11c6815ca51 (diff)
downloadaur-df9ffc7c29073059801e0a82331c0d4b5193da3e.tar.gz
fix npm shit
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d56faec1b17..9ba76f0bd697 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=pb-git
-pkgver=r269.61d49ec
+pkgver=r276.e6cc4e6
pkgrel=1
pkgdesc="My attempt at a light pastebin"
arch=('any')
@@ -9,7 +9,7 @@ license=('GPLv3')
depends=('python' 'python-werkzeug' 'python-flask-git' 'python-yaml'
'python-requests' 'python-docutils' 'python-xdg'
'python-pymongo' 'python-markdown' 'python-dateutil'
- 'python-magic' 'uwsgi' 'uwsgi-plugin-python')
+ 'python-magic-git' 'uwsgi' 'uwsgi-plugin-python')
makedepends=('python-setuptools' 'git' 'graphicsmagick' 'npm')
#checkdepends=('tox' 'python-pytest' 'python-pytest-cov')
@@ -31,6 +31,12 @@ prepare() {
npm install
npm install grunt-cli
+ # npm and grunt are retarded pieces of shit
+ (
+ cd node_modules/pbs
+ npm install
+ )
+
node_modules/grunt-cli/bin/grunt
}