summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXyne2015-06-21 02:20:29 +0000
committerXyne2015-06-21 02:20:29 +0000
commit3905d08b1f17cc617b364ac125665de35639a517 (patch)
treee1bfd3013ba1255cf3d2f30fffb3063e86be1bae
downloadaur-3905d08b1f17cc617b364ac125665de35639a517.tar.gz
Initial import.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d83e20a72e59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pbget
+ pkgdesc = Retrieve PKGBUILDs and local source files from Git, ABS and the AUR for makepkg.
+ pkgver = 2013.12
+ pkgrel = 1
+ url = http://xyne.archlinux.ca/projects/pbget
+ arch = any
+ license = GPL
+ depends = python3
+ optdepends = rsync: ABS tree support
+ optdepends = python3-aur: AUR support
+ optdepends = pyalpm: checking upgradable packages
+ source = http://xyne.archlinux.ca/projects/pbget/src/pbget-2013.12.tar.xz
+ source = http://xyne.archlinux.ca/projects/pbget/src/pbget-2013.12.tar.xz.sig
+ md5sums = e1dbbaad8ed0788251ee4e0147f5a5d0
+ md5sums = 4078e87ea93fcca1c037493816c8b697
+ sha512sums = 4aa3eb9481e5208dd20d4e07af5699bb177353b04a7b587285c9edfed0df0ca1c6acf8ae12fa1a8db36d15799255d7010b5d9a267cbfe0c072af093ce46eb7f1
+ sha512sums = 38079e8d871b696cce17991e18180d22383de82acf64169be2077dbe95f27589aef7ace8774e487dff0ae8bdbc4f8a2288c7e820d5fed0d048addb2b0ead7586
+
+pkgname = pbget
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b515e6e1fcc1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+#Maintainer: Xyne <ac xunilhcra enyx, backwards>
+pkgname=pbget
+pkgver=2013.12
+pkgrel=1
+pkgdesc='Retrieve PKGBUILDs and local source files from Git, ABS and the AUR for makepkg.'
+arch=(any)
+license=(GPL)
+url="http://xyne.archlinux.ca/projects/pbget"
+depends=(python3)
+optdepends=('rsync: ABS tree support' 'python3-aur: AUR support' 'pyalpm: checking upgradable packages')
+source=(
+ http://xyne.archlinux.ca/projects/pbget/src/pbget-2013.12.tar.xz
+ http://xyne.archlinux.ca/projects/pbget/src/pbget-2013.12.tar.xz.sig
+)
+sha512sums=(
+ 4aa3eb9481e5208dd20d4e07af5699bb177353b04a7b587285c9edfed0df0ca1c6acf8ae12fa1a8db36d15799255d7010b5d9a267cbfe0c072af093ce46eb7f1
+ 38079e8d871b696cce17991e18180d22383de82acf64169be2077dbe95f27589aef7ace8774e487dff0ae8bdbc4f8a2288c7e820d5fed0d048addb2b0ead7586
+)
+md5sums=(
+ e1dbbaad8ed0788251ee4e0147f5a5d0
+ 4078e87ea93fcca1c037493816c8b697
+)
+validpgpkeys=('EC3CBE7F607D11E663149E811D1F0DC78F173680')
+
+package ()
+{
+ install -Dm755 "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
+
+
+# vim: set ts=2 sw=2 et: