summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Preinstorfer2020-06-20 10:19:39 +0200
committerFlorian Preinstorfer2020-06-20 10:19:39 +0200
commit7cbdf9dc934ceb1baa092c68e9e76e065960e27e (patch)
tree4218b9f6a1dc372c9600ce9fa0210c608fcee3f6
parent372137220c7d71300eac3f0eecf17d791d6f4e62 (diff)
downloadaur-7cbdf9dc934ceb1baa092c68e9e76e065960e27e.tar.gz
Release 0.3.1
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD17
-rw-r--r--requirements.txt4
4 files changed, 9 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92aeebe33d17..9438641aaa06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pbincli
pkgdesc = A command line client for PrivateBin
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/r4sas/PBinCLI
arch = any
@@ -11,15 +11,9 @@ pkgbase = pbincli
depends = python-pycryptodome
depends = python-requests
depends = python-sjcl
- source = https://files.pythonhosted.org/packages/source/P/PBinCLI/PBinCLI-0.3.0.tar.gz
- source = requirements.txt
- source = LICENSE
- sha1sums = 844fd7b46f4f437f1ab4de62c4ea3c018b60bfc0
- sha1sums = c3409930f9cc1b2f86873d299f54a4ad818a86c1
- sha1sums = 5a9f9ba2f34d243125d05d36361a407257cb528d
- sha256sums = 261b05dfcd471675d6442fed8eb779a7f8c2817fe29b5204ff9fc8a03b47d089
- sha256sums = b9c0f5fe9a218463a4a1fe687efe7a351a6ffec083961a2dde007d0ded0e350f
- sha256sums = ad9f1d1dbb64e58c270f73a65b4945d430a74b41c01f643ed6bb550071b50969
+ source = https://files.pythonhosted.org/packages/source/P/PBinCLI/PBinCLI-0.3.1.tar.gz
+ sha1sums = b06e1e7130143eee98a69a3e210c3b4f58b528b5
+ sha256sums = a7db80ef1c842f73db04996602db32085e65a9026115cf534b08a650d2f05dc5
pkgname = pbincli
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index afed360711e3..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,7 +0,0 @@
-Copyright 2017 © R4SAS <r4sas@i2pmail.org>
-
-Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 9c561d6a91df..d025d878e571 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pbincli
_name="PBinCLI"
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc='A command line client for PrivateBin'
arch=('any')
@@ -14,24 +14,17 @@ depends=('python'
'python-requests'
'python-sjcl')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
- "requirements.txt"
- "LICENSE")
-sha1sums=('844fd7b46f4f437f1ab4de62c4ea3c018b60bfc0'
- 'c3409930f9cc1b2f86873d299f54a4ad818a86c1'
- '866615726030714e001269a8085114f070dbac05')
-sha256sums=('261b05dfcd471675d6442fed8eb779a7f8c2817fe29b5204ff9fc8a03b47d089'
- 'b9c0f5fe9a218463a4a1fe687efe7a351a6ffec083961a2dde007d0ded0e350f'
- 'e0b9ef9ff5d625fc9eb0ca287dc5a8798bbc631b6818742b96b1f8c7b6b30c65')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha1sums=('b06e1e7130143eee98a69a3e210c3b4f58b528b5')
+sha256sums=('a7db80ef1c842f73db04996602db32085e65a9026115cf534b08a650d2f05dc5')
build() {
cd "$_name-$pkgver"
- cp ../requirements.txt .
python setup.py build
}
package() {
cd "$_name-$pkgver"
- install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
diff --git a/requirements.txt b/requirements.txt
deleted file mode 100644
index 29a9b41d1716..000000000000
--- a/requirements.txt
+++ /dev/null
@@ -1,4 +0,0 @@
-pycryptodome
-sjcl
-base58
-requests