summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangseo Jang2021-10-30 15:48:23 +0900
committerChangseo Jang2021-10-30 15:48:23 +0900
commit9f2718a21c2a90dda4ef35c1ccadc370c0f48dbf (patch)
treec54d4ed32d11868f2b93fa3b83c3efa2fb783e97
downloadaur-9f2718a21c2a90dda4ef35c1ccadc370c0f48dbf.tar.gz
Init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1252d360c085
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pbkit
+ pkgdesc = Protobuf Dependency Manager
+ pkgver = v0.0.22
+ pkgrel = 1
+ arch = x86_64
+ license = MIT
+ license = APACHE
+ makedepends = git
+ makedepends = deno
+ provides = pollapo
+ provides = pb
+ source = pbkit::git://github.com/pbkit/pbkit.git#tag=v0.0.22
+ sha256sums = SKIP
+
+pkgname = pbkit
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9feef666d8f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Changseo Jang <changseo.jang@korea.edu>
+pkgname='pbkit'
+pkgver='v0.0.22'
+pkgrel=1
+epoch=
+pkgdesc='Protobuf Dependency Manager'
+arch=('x86_64')
+url=''
+license=('MIT' 'APACHE')
+groups=()
+depends=()
+makedepends=('git' 'deno')
+checkdepends=()
+optdepends=()
+provides=('pollapo' 'pb')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("pbkit::git://github.com/pbkit/pbkit.git#tag=${pkgver}")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+package() {
+ deno install --unstable -A -n pollapo "$srcdir/pbkit/cli/pollapo/entrypoint.ts"
+ deno install --unstable -A -n pb "$srcdir/pbkit/cli/pb/entrypoint.ts"
+}