summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Ivanov2015-06-23 10:20:41 +0200
committerPeter Ivanov2015-06-23 10:20:41 +0200
commit3c499734bb64f7c6b8f42b2f9fdbd8c96805f7a5 (patch)
treedf7130af1ef48afb5f33b874b17e6698a609d660
downloadaur-3c499734bb64f7c6b8f42b2f9fdbd8c96805f7a5.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
-rw-r--r--pblazasm.patch43
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6889fb9c09f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pblazasm
+ pkgdesc = Command line tool to assemble Picoblaze code in Xilinx, pBlazIDE or extended syntax
+ pkgver = 1.2
+ pkgrel = 2
+ url = http://code.google.com/p/pblazasm/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = svn
+ options = !strip
+ source = pblazasm.patch
+ md5sums = d1238c80c6dc408a839f460b48e84ba0
+
+pkgname = pblazasm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e3ccb643c56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Peter Ivanov <ivanovp@gmail.com>
+
+pkgname=pblazasm
+pkgver=1.2
+pkgrel=2
+pkgdesc="Command line tool to assemble Picoblaze code in Xilinx, pBlazIDE or extended syntax"
+arch=("i686" "x86_64")
+url="http://code.google.com/p/pblazasm/"
+license=("GPL3")
+depends=()
+makedepends=(svn)
+options=('!strip')
+source=(pblazasm.patch)
+md5sums=(d1238c80c6dc408a839f460b48e84ba0)
+
+_svnroot=http://pblazasm.googlecode.com/svn/trunk
+#_svnname=pblazasm-read-only
+
+build() {
+ msg "Connecting to SVN server..."
+ if [[ -d $srcdir/$pkgname-$pkgver ]]; then
+ cd $srcdir/$pkgname-$pkgver && svn update || return 1
+ else
+ svn co $_svnroot $srcdir/$pkgname-$pkgver || return 1
+ cd $srcdir/$pkgname-$pkgver
+ fi
+
+ msg "SVN checkout done or server timeout"
+ cd "$srcdir/$pkgname-$pkgver/pBlazASM"
+ if [ ! -f pblazasm.patched ]; then
+ patch -p0 < ../../pblazasm.patch
+ touch pblazasm.patched
+ fi
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/pBlazASM"
+ install -d ${pkgdir}/usr/bin
+ install -Dm755 pBlazASM ${pkgdir}/usr/bin/pblazasm
+}
diff --git a/pblazasm.patch b/pblazasm.patch
new file mode 100644
index 000000000000..54430ca3674d
--- /dev/null
+++ b/pblazasm.patch
@@ -0,0 +1,43 @@
+--- Makefile.orig 2011-07-12 07:48:36.656784380 +0200
++++ Makefile 2011-07-12 07:49:16.283451761 +0200
+@@ -12,7 +12,7 @@
+ #MP = "C:/Qt/2010.04/mingw/include"
+ #CC = "C:/Qt/2010.04/mingw/bin/gcc"
+ MP = "C:/tcc/inc"
+-CC = "C:/tcc/tcc"
++CC = gcc
+
+
+ C_SRCS += \
+@@ -23,7 +23,7 @@
+ ./pbSymbols.c \
+ ./getopt.c
+
+-EXE = "./pBlazASM.exe"
++EXE = "./pBlazASM"
+ OBJS = $(C_SRCS:.c=.o)
+ LIBS =
+ INCS = -I$(MP) -I"../inc"
+@@ -33,7 +33,7 @@
+ ## rules
+
+ # All Target
+-all: test
++all: $(EXE)
+
+ test: $(EXE)
+ $(EXE) -l -m pBlazASM_Syntax.psm
+--- pbParser.c.orig 2011-07-12 07:50:42.186787239 +0200
++++ pbParser.c 2011-07-12 07:50:44.376787312 +0200
+@@ -28,9 +28,9 @@
+ #include "pbLexer.h"
+ #include "pbErrors.h"
+
+-//#ifdef _MSC_VER //Microsoft Visual C doesn't have strcasemcp, but has stricmp instead
++#ifdef _MSC_VER //Microsoft Visual C doesn't have strcasemcp, but has stricmp instead
+ #define strcasecmp stricmp
+-//#endif
++#endif
+
+
+ /**