summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Schrempf2018-04-09 10:06:31 +0200
committerDominik Schrempf2018-04-09 10:06:31 +0200
commit45b075dd108ea671b788711648ef173260441583 (patch)
treeef56e497c1a8ad091fe4961d980ffffb6ebcd539
downloadaur-45b075dd108ea671b788711648ef173260441583.tar.gz
Initial commit. Version 1.7.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cbae811995d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pbmpi2-git
+ pkgdesc = Efficient phylogenomic tree reconstruction using Bayesian statistics; multicore version (MPI)
+ pkgver = 1.7.675fab8
+ pkgrel = 1
+ url = http://www.atgc-montpellier.fr/phylobayes/
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ depends = openmpi
+ source = pbmpi2-git::git+https://github.com/bayesiancook/pbmpi2.git
+ md5sums = SKIP
+
+pkgname = pbmpi2-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..169f13ca66ce
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.xz
+/pkg
+/src
+*.tar.gz
+/update
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..962889b8ed29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dominik Schrempf <dominik dot schrempf at gmail dot com>
+pkgname=pbmpi2-git
+_gitname=pbmpi2
+pkgver=1.7.675fab8
+pkgrel=1
+pkgdesc="Efficient phylogenomic tree reconstruction using Bayesian statistics; multicore version (MPI)"
+arch=(x86_64)
+url="http://www.atgc-montpellier.fr/phylobayes/"
+license=('GPL2')
+depends=('glibc' 'openmpi')
+makedepends=('git')
+# Does not conflict because executable names differ.
+# conflicts=('phylobayes' 'phylobayes-mpi')
+source=("${pkgname}::git+https://github.com/bayesiancook/${_gitname}.git")
+md5sums=('SKIP')
+noextract=()
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ mkdir build
+ cd sources
+ # TODO: CONSTEXPR required to compile without '-fpermissive'.
+ make CPPFLAGS="-w -O3 -c -fpermissive" -j4
+}
+
+
+package() {
+ cd "$srcdir/$pkgname"
+ # TODO: Also install other software parts.
+ install -D -m755 "data/pb_mpi" "${pkgdir}/usr/bin/pb_mpi"
+ install -D -m755 "data/readpb_mpi" "${pkgdir}/usr/bin/readpb_mpi"
+}