summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormdomlop2018-09-05 09:20:28 +0200
committermdomlop2018-09-05 09:20:28 +0200
commit658d0d3d20a074b875d112ceea88b48ffda109fc (patch)
treefe103a6f5f8de30bddcc1821db143dc4b01bef1d
downloadaur-658d0d3d20a074b875d112ceea88b48ffda109fc.tar.gz
Release 1.0b
-rw-r--r--.SRCINFO15
-rw-r--r--ChangeLog21
-rw-r--r--PKGBUILD31
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b92d257bf22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pbscrap
+ pkgdesc = A simple pastebin.com scraper.
+ pkgver = 1.0b
+ pkgrel = 1
+ url = https://github.com/mdomlop/pbscrap
+ changelog = ChangeLog
+ arch = any
+ license = GPL3
+ depends = python>=3
+ depends = python-urllib3
+ source = https://github.com/mdomlop/pbscrap/archive/1.0b.tar.gz
+ md5sums = abfa14099d06214cc6456a2c0eaf3779
+
+pkgname = pbscrap
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..980807c191eb
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,21 @@
+2017-03-29 Manuel Domínguez López <mdomlop@gmail.com>
+
+ * Version 0.3a
+
+ * src/pbscrap.py: Reads infile in each frecuency-loop execution. This
+ allow dynamically changes in queries without stop process.
+
+ * BUGS.md: Added BUGS.md file.
+
+ * Version 0.2b.
+
+ * src/pbscrap.py: Now findings are stored and logged in groups.
+
+ * src/pbscrap.py: No problems with OS directory separators. Now you can
+ search for things like /etc/passwd
+
+ * src/pbscrap.py: Minor optimizations.
+
+ * ChangeLog: Added ChangeLog file.
+
+ * Version 0.1a. First alpha release
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60f3c5352535
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Manuel Domínguez López <mdomlop at gmail dot com>
+
+_pkgver_year=2017
+_pkgver_month=09
+_pkgver_day=05
+
+pkgname=pbscrap
+pkgver=1.0b
+pkgrel=1
+pkgdesc="A simple pastebin.com scraper."
+arch=('any')
+
+url="https://github.com/mdomlop/$pkgname"
+source=("https://github.com/mdomlop/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('abfa14099d06214cc6456a2c0eaf3779')
+
+license=('GPL3')
+
+depends=('python>=3' 'python-urllib3')
+changelog=ChangeLog
+
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+ }
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make install DESTDIR=$pkgdir
+}