summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarin2017-02-21 10:20:34 +0100
committerMarin2017-02-21 10:20:34 +0100
commit898cbe54d4ded504c9db31a56edcbd01b5b6c0e6 (patch)
tree68dffdde26d8f2ad001191a54528e579361c1f1d
parentd583bff0d45dd450eea0175e3803f36d7b4dbd20 (diff)
downloadaur-898cbe54d4ded504c9db31a56edcbd01b5b6c0e6.tar.gz
Remove needless other platforms binaries
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4acbf939a888..bdb3941e86af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = pbtk-git
pkgdesc = A toolset for reverse engineering and fuzzing Protobuf-based apps
pkgver = 1.0.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/marin-m/pbtk
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL3
makedepends = git
+ makedepends = findutils
depends = python-pyqt5
depends = python-protobuf
depends = python-requests
depends = python-websocket-client
depends = qt5-webengine
depends = chromium
- depends = jad
- depends = dex2jar
+ depends = java-runtime
source = git+https://github.com/marin-m/pbtk
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3f633bb579c7..60b23a9c84f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=pbtk-git
pkgver=1.0.4
-pkgrel=1
+pkgrel=2
pkgdesc='A toolset for reverse engineering and fuzzing Protobuf-based apps'
url='https://github.com/marin-m/pbtk'
-arch=('any')
+arch=('i686' 'x86_64')
license=('GPL3')
-depends=('python-pyqt5' 'python-protobuf' 'python-requests' 'python-websocket-client' 'qt5-webengine' 'chromium' 'jad' 'dex2jar')
-makedepends=('git')
+depends=('python-pyqt5' 'python-protobuf' 'python-requests' 'python-websocket-client' 'qt5-webengine' 'chromium' 'java-runtime')
+makedepends=('git' 'findutils')
source=('git+https://github.com/marin-m/pbtk')
sha512sums=('SKIP')
@@ -24,8 +24,10 @@ package() {
cd pbtk
install -Dm 755 ../pbtk.sh "${pkgdir}/usr/bin/pbtk"
install -Dm 755 gui.py -t "${pkgdir}/usr/share/pbtk"
- chmod -R 755 extractors
+
+ find . -regex '.*\(\.bat\|\.exe\|_osx\)' -type f -delete
+ chmod -R 755 extractors utils/external
+
cp -r extractors utils views "${pkgdir}/usr/share/pbtk"
- # install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/pbtk"
install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/pbtk"
}