summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarin2017-02-15 00:03:02 +0100
committerMarin2017-02-15 00:03:02 +0100
commit9cc0d30a919c1232d00d82206c95d82199f1bfdf (patch)
tree8f0739c52f7100d4c78c4ead6809aa75848d165e
downloadaur-9cc0d30a919c1232d00d82206c95d82199f1bfdf.tar.gz
First commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bb0dc7fb13a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pbtk-git
+ pkgdesc = A toolset for reverse engineering and fuzzing Protobuf-based apps
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/marin-m/pbtk
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python-pyqt5
+ depends = python-protobuf
+ depends = python-requests
+ depends = python-websocket-client
+ depends = qt5-webengine
+ depends = chromium
+ depends = jad
+ depends = dex2jar
+ source = git+https://github.com/marin-m/pbtk
+ sha512sums = SKIP
+
+pkgname = pbtk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b6689f1649f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Marin M <https://github.com/marin-m>
+
+pkgname=pbtk-git
+pkgver=1
+pkgrel=1
+pkgdesc='A toolset for reverse engineering and fuzzing Protobuf-based apps'
+url='https://github.com/marin-m/pbtk'
+arch=('any')
+license=('GPL3')
+depends=('python-pyqt5' 'python-protobuf' 'python-requests' 'python-websocket-client' 'qt5-webengine' 'chromium' 'jad' 'dex2jar')
+makedepends=('git')
+source=('git+https://github.com/marin-m/pbtk')
+sha512sums=('SKIP')
+
+prepare() {
+ cat > pbtk.sh << EOF
+#!/bin/bash
+cd /usr/share/pbtk/
+exec ./gui.py "\$@"
+EOF
+}
+
+package() {
+ cd inguma-pbtk-*
+ install -Dm 755 pbtk.sh "${pkgdir}/usr/bin/pbtk"
+ install -Dm 755 gui.py extractors -t "${pkgdir}/usr/share/pbtk"
+ cp -r utils views "${pkgdir}/usr/share/pbtk"
+ # install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+}