summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Joost van de Sande2021-09-10 09:02:20 +0200
committerPieter Joost van de Sande2021-09-10 09:02:20 +0200
commit878f60d5b83f1504bc1ebedbca7095c04f99e818 (patch)
tree3195c5d8d23a310895aacb71ce8cd7191cbb62e0
downloadaur-878f60d5b83f1504bc1ebedbca7095c04f99e818.tar.gz
v6.1.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97d0ae2d9a4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pc-nrfutil
+ pkgdesc = nrfutil command line utility and the nordicsemi library
+ pkgver = 6.1.2
+ pkgrel = 1
+ url = https://github.com/NordicSemiconductor/pc-nrfutil
+ arch = any
+ license = BSD
+ depends = python
+ provides = nrfutil
+ options = !emptydirs
+ source = https://github.com/NordicSemiconductor/pc-nrfutil/releases/download/v6.1.2/nrfutil-linux
+ sha256sums = a384e3eb09133054e3006af2033bd497f466a0ae4c2a6dd75e895afaad3c53e3
+
+pkgname = pc-nrfutil
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2544fb61ec8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Pieter Joost van de Sande <pj@born2code.net>
+
+pkgname=pc-nrfutil
+provides=('nrfutil')
+pkgver=6.1.2
+pkgrel=1
+pkgdesc="nrfutil command line utility and the nordicsemi library"
+arch=('any')
+url="https://github.com/NordicSemiconductor/pc-nrfutil"
+license=('BSD')
+depends=('python')
+options=(!emptydirs)
+source=(${url}/releases/download/v${pkgver}/nrfutil-linux)
+sha256sums=('a384e3eb09133054e3006af2033bd497f466a0ae4c2a6dd75e895afaad3c53e3')
+
+package() {
+ install -dm0755 $pkgdir/usr/bin
+ cp ${srcdir}/nrfutil-linux $pkgdir/usr/bin/nrfutil
+ chmod +x $pkgdir/usr/bin/nrfutil
+}
+