summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2020-11-30 12:56:42 +0100
committerPhilipp A2020-11-30 12:56:42 +0100
commitc2c06e3c71d96b2c289dc9462a425c7383298b78 (patch)
tree77273688cedf65857f8864732ace4b9a1c24d48d
downloadaur-c2c06e3c71d96b2c289dc9462a425c7383298b78.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fc07a7059cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pcaper
+ pkgdesc = Read pcap and assemble HTTP requests
+ pkgver = 1.0.11
+ pkgrel = 1
+ url = https://github.com/gaainf/pcaper/pcaper
+ arch = any
+ license = BSD
+ depends = python
+ depends = python-dpkt>=1.9.1
+ depends = python-six>=1.11.0
+ depends = python-dateutil>=2.8.0
+ noextract = pcaper-1.0.11-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/p/pcaper/pcaper-1.0.11-py2.py3-none-any.whl
+ sha256sums = 4aa52c95ddb0a279549f07d271940c03f79a3d06089b1f5081b4c12d60d956e2
+
+pkgname = pcaper
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb3cc40a81f9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.pkg.tar.xz
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efc52a1c7359
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+pkgname=pcaper
+pkgver=1.0.11
+pkgrel=1
+pkgdesc='Read pcap and assemble HTTP requests'
+arch=(any)
+url="https://github.com/gaainf/pcaper/$pkgname"
+license=(BSD)
+depends=(
+ python
+ 'python-dpkt>=1.9.1'
+ 'python-six>=1.11.0'
+ 'python-dateutil>=2.8.0'
+)
+_wheel="$pkgname-$pkgver-py2.py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py2.py3/${pkgname::1}/$pkgname/$_wheel")
+sha256sums=('4aa52c95ddb0a279549f07d271940c03f79a3d06089b1f5081b4c12d60d956e2')
+noextract=("$_wheel")
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ install -d "$site"
+ unzip "$_wheel" -d "$site"
+ install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
+}