summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-02-19 16:31:32 +0100
committerPhilipp A2022-02-19 16:31:32 +0100
commiteb56773df5cd50b02aa2b4a94295dac6b6e9b4ef (patch)
treee85bed01cb63f73c30b649cc01e5c181d983f5a2
parentc2c06e3c71d96b2c289dc9462a425c7383298b78 (diff)
downloadaur-eb56773df5cd50b02aa2b4a94295dac6b6e9b4ef.tar.gz
build from source
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fc07a7059cc..7ace9d0993b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = pcaper
pkgdesc = Read pcap and assemble HTTP requests
pkgver = 1.0.11
- pkgrel = 1
- url = https://github.com/gaainf/pcaper/pcaper
+ pkgrel = 2
+ url = https://github.com/gaainf/pcaper
arch = any
license = BSD
+ makedepends = python-build
+ makedepends = python-installer
depends = python
depends = python-dpkt>=1.9.1
depends = python-six>=1.11.0
depends = python-dateutil>=2.8.0
- noextract = pcaper-1.0.11-py2.py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py2.py3/p/pcaper/pcaper-1.0.11-py2.py3-none-any.whl
- sha256sums = 4aa52c95ddb0a279549f07d271940c03f79a3d06089b1f5081b4c12d60d956e2
+ source = https://files.pythonhosted.org/packages/source/p/pcaper/pcaper-1.0.11.tar.gz
+ sha256sums = 65f9aea7ec97f42fbdf10ae8a6695226fe773499ef2eb477c724f998d7972075
pkgname = pcaper
-
diff --git a/.gitignore b/.gitignore
index cb3cc40a81f9..c5d85b20091f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/src/
/pkg/
-/*.pkg.tar.xz
-/*.whl
+/*.pkg.*
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index efc52a1c7359..ec69fb92e4b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=pcaper
pkgver=1.0.11
-pkgrel=1
+pkgrel=2
pkgdesc='Read pcap and assemble HTTP requests'
arch=(any)
-url="https://github.com/gaainf/pcaper/$pkgname"
+url="https://github.com/gaainf/$pkgname"
license=(BSD)
depends=(
python
@@ -13,14 +13,16 @@ depends=(
'python-six>=1.11.0'
'python-dateutil>=2.8.0'
)
-_wheel="$pkgname-$pkgver-py2.py3-none-any.whl"
-source=("https://files.pythonhosted.org/packages/py2.py3/${pkgname::1}/$pkgname/$_wheel")
-sha256sums=('4aa52c95ddb0a279549f07d271940c03f79a3d06089b1f5081b4c12d60d956e2')
-noextract=("$_wheel")
+makedepends=(python-build python-installer)
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('65f9aea7ec97f42fbdf10ae8a6695226fe773499ef2eb477c724f998d7972075')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
- install -d "$site"
- unzip "$_wheel" -d "$site"
- install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}