summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormcgyver2023-04-25 17:33:27 +0100
committermcgyver2023-04-25 17:33:27 +0100
commit43754d89b7c9a7d0d1780f907d0fb3c1caf6ccbb (patch)
tree07ec5da479ef01f9437c9e28faea16f854c018a4
parentc293fdba3b93ec9362a454d5b453aa4aea9bb6e0 (diff)
downloadaur-43754d89b7c9a7d0d1780f907d0fb3c1caf6ccbb.tar.gz
updating he formatting of the PKGBUILD file
-rw-r--r--PKGBUILD21
1 files changed, 5 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f32876a73542..3994459a637e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,25 +18,14 @@ pkgver() {
}
build() {
- cd "pcapplusplus"
- mkdir -p "build"
- cd build
- cmake -DBUILD_SHARED_LIBS=ON -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_INSTALL_LIBDIR='/usr/lib/pcapplusplus' ..
- make
+ cd "pcapplusplus"
+ mkdir -p "build"
+ cd build
+ cmake -DBUILD_SHARED_LIBS=ON -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_INSTALL_LIBDIR='/usr/lib/pcapplusplus' ..
+ make
}
package() {
cd "$srcdir/pcapplusplus/build"
make DESTDIR="$pkgdir" install
}
-
-
-#package() {
-# cd "pcapplusplus/Dist" || exit 1
-# mkdir -p "$pkgdir/usr/bin"
-# cp examples/* "$pkgdir/usr/bin"
-# mkdir -p "$pkgdir/usr/include/pcapplusplus"
-# cp header/* "$pkgdir/usr/include/pcapplusplus"
-# mkdir -p "$pkgdir/usr/lib/pcapplusplus"
-# cp ./*.a "$pkgdir/usr/lib/pcapplusplus"
-#}