summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormcgyver2023-04-25 13:17:32 +0100
committermcgyver2023-04-25 13:17:32 +0100
commit54619c29193ff990ac83396d4007548e8c81d247 (patch)
treefdfb7c6d0c555aaa61d3ea4ecdd189c13018b15b
downloadaur-54619c29193ff990ac83396d4007548e8c81d247.tar.gz
initial submission of the PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..843ba34d666e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pcapplusplus-git
+ pkgdesc = A multi-platform C++ library for capturing, parsing and crafting of network packets
+ pkgver = 22.11.r104.gfb3a5604
+ pkgrel = 1
+ url = https://pcapplusplus.github.io/
+ arch = x86_64
+ license = Unlicense
+ makedepends = git
+ depends = libpcap
+ depends = glibc
+ depends = gcc-libs
+ source = pcapplusplus::git+https://github.com/seladb/PcapPlusPlus.git
+ sha256sums = SKIP
+
+pkgname = pcapplusplus-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24a41ff4decf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: mcgyver <newsletter.sergio@gmail.com>
+
+pkgname=pcapplusplus-git
+pkgver=22.11.r104.gfb3a5604
+pkgrel=1
+pkgdesc="A multi-platform C++ library for capturing, parsing and crafting of network packets"
+arch=("x86_64")
+url="https://pcapplusplus.github.io/"
+license=('Unlicense')
+makedepends=("git")
+depends=("libpcap" "glibc" "gcc-libs")
+source=("pcapplusplus::git+https://github.com/seladb/PcapPlusPlus.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "pcapplusplus"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/\./g'
+}
+
+build() {
+ cd "pcapplusplus"
+ mkdir -p "build"
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX='/usr' ..
+ make
+}
+
+package() {
+ cd "$srcdir/pcapplusplus/build"
+ make DESTDIR="$pkgdir" install
+}
+
+
+#package() {
+# cd "pcapplusplus/Dist" || exit 1
+# mkdir -p "$pkgdir/usr/bin"
+# cp examples/* "$pkgdir/usr/bin"
+# mkdir -p "$pkgdir/usr/include/pcapplusplus"
+# cp header/* "$pkgdir/usr/include/pcapplusplus"
+# mkdir -p "$pkgdir/usr/lib/pcapplusplus"
+# cp ./*.a "$pkgdir/usr/lib/pcapplusplus"
+#}