summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle2016-02-08 07:59:48 -0500
committerKyle2016-02-08 07:59:48 -0500
commitcbc0ec0b464dc75f72ea674af87650852f5bb880 (patch)
treea1c3699dd894667b9acb4a7744593fb1e6548c84
downloadaur-cbc0ec0b464dc75f72ea674af87650852f5bb880.tar.gz
Initial release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e1cfb17f428
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Feb 8 12:58:53 UTC 2016
+pkgbase = pcaudiolib-git
+ pkgdesc = Portable C Audio Library (git version)
+ pkgver = b5b2860
+ pkgrel = 1
+ url = https://github.com/rhdunn/pcaudiolib
+ arch = armv6h
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ optdepends = alsa-lib: ALSA output support
+ optdepends = pulseaudio: Pulseaudio output support
+ source = git+https://github.com/rhdunn/pcaudiolib.git
+ md5sums = SKIP
+
+pkgname = pcaudiolib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..081858c54951
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Kyle <kyle@gmx.ca>
+pkgname=pcaudiolib-git
+_gitname=pcaudiolib
+pkgver=b5b2860 # determined from git origin
+pkgrel=1
+pkgdesc="Portable C Audio Library (git version)"
+arch=(armv6h armv7h i686 x86_64)
+url="https://github.com/rhdunn/pcaudiolib"
+license=('GPL3')
+depends=()
+optdepends=('alsa-lib: ALSA output support'
+ 'pulseaudio: Pulseaudio output support')
+makedepends=('git')
+provides=()
+conflicts=()
+source=('git+https://github.com/rhdunn/pcaudiolib.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ # Use the tag of the last commit
+ git describe --always | sed -e 's|v||' -e 's|-|.|g'
+}
+
+build() {
+ cd $_gitname
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: