summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Blankertz2015-06-12 16:54:16 +0200
committerMatthias Blankertz2015-06-12 16:54:16 +0200
commitd74b8c0378a25132e7b7fb195bde6448b31b724b (patch)
treebe8e7883d4461668202044c39b87a09c2e788a5f
downloadaur-d74b8c0378a25132e7b7fb195bde6448b31b724b.tar.gz
Initial import to AUR4
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
-rw-r--r--pcb.install37
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e26b0300df67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pcb
+ pkgdesc = Interactive printed circuit board editor
+ pkgver = 20140316
+ pkgrel = 1
+ url = http://pcb.geda-project.org/
+ install = pcb.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = tk
+ depends = gtkglext
+ depends = gd
+ optdepends = tk: additional tools
+ optdepends = tcl: additional tools
+ optdepends = perl: additional tools
+ optdepends = desktop-file-utils: desktop integration
+ source = http://downloads.sourceforge.net/pcb/pcb-20140316.tar.gz
+ sha1sums = ec714ff136d1817e500e1a9e654e786883b9501e
+
+pkgname = pcb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb907466dfd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Matthias Blankertz <matthias at blankertz dot org>
+# Contributor: Egon Geerardyn <egon dot geerardyn at gmail dot com>
+# Contributor: kfgz <kfgz at interia pl>
+# Contributor: Gaetan Bisson <bisson at archlinux dot org>
+# Contributor: Jared Casper <jaredcasper at gmail dot com>
+# Contributor: Stefan Husmann <stefan-husmann at t-online dot de>
+
+pkgname=pcb
+pkgver=20140316
+pkgrel=1
+pkgdesc='Interactive printed circuit board editor'
+url='http://pcb.geda-project.org/'
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('gtkglext' 'gd')
+optdepends=('tk: additional tools'
+ 'tcl: additional tools'
+ 'perl: additional tools'
+ 'desktop-file-utils: desktop integration')
+makedepends=('intltool' 'tk')
+source=("http://downloads.sourceforge.net/pcb/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('ec714ff136d1817e500e1a9e654e786883b9501e')
+install=pcb.install
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --enable-dbus \
+ --disable-update-mime-database \
+ --disable-update-desktop-database
+ make
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make -j1 prefix="${pkgdir}"/usr install
+
+ rm "${pkgdir}"/usr/share/info/dir
+}
diff --git a/pcb.install b/pcb.install
new file mode 100644
index 000000000000..62ce80440970
--- /dev/null
+++ b/pcb.install
@@ -0,0 +1,37 @@
+infodir=/usr/share/info
+filelist=(pcb.info pcb.info-1 pcb.info-2)
+
+post_install() {
+ if [ -x /usr/bin/update-mime-database ]; then
+ echo Updating mime database...
+ /usr/bin/update-mime-database /usr/share/mime
+ fi
+ if [ -x /usr/bin/update-desktop-database ]; then
+ echo Updating desktop database..
+ /usr/bin/update-desktop-database /usr/share/applications
+ fi
+ if [ -x /usr/bin/install-info ]; then
+ echo Updating info directory...
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+ fi
+ /usr/bin/gtk-update-icon-cache -f -t /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ if [ -x /usr/bin/install-info ]; then
+ echo Updating info directory...
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+ fi
+}
+
+post_remove() {
+ /usr/bin/gtk-update-icon-cache -f -t /usr/share/icons/hicolor
+}