summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2016-08-22 10:06:36 -0400
committerKyle Keen2016-08-22 10:06:36 -0400
commitdcab66d307987d13c017e1d28a2647d35eb068ab (patch)
treeacb56bd4eea87efe4c3fb4c9192bcd57296d62a3
downloadaur-dcab66d307987d13c017e1d28a2647d35eb068ab.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccd72b71ea73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon Aug 22 14:06:36 UTC 2016
+pkgbase = pcb-rnd
+ pkgdesc = Fork of Geda-PCB with embedded scripting and other improvements.
+ pkgver = r2689
+ pkgrel = 1
+ url = http://repo.hu/projects/pcb-rnd/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = svn
+ depends = gd
+ depends = libjpeg
+ depends = lesstif
+ depends = gtk2
+ provides = pcb-rnd
+ conflicts = pcb-rnd
+ source = svn://repo.hu/pcb-rnd/trunk
+ md5sums = SKIP
+
+pkgname = pcb-rnd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f41db56dc2d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com?>
+pkgname=pcb-rnd
+_pkgname=pcb-rnd
+pkgver=r2689
+pkgrel=1
+pkgdesc="Fork of Geda-PCB with embedded scripting and other improvements."
+url="http://repo.hu/projects/pcb-rnd/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('gd' 'libjpeg' 'lesstif' 'gtk2')
+# - glib and gtk if you are using the gtk frontend
+# - motif or lesstif if you are using the lesstif frontend
+# - gdlib if you are using the png HID
+makedepends=('svn')
+provides=('pcb-rnd')
+conflicts=('pcb-rnd')
+source=("svn://repo.hu/pcb-rnd/trunk")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/trunk/"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "$srcdir/trunk/"
+ # many knobs under ./configure --help
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/trunk/"
+ # prefix? DESTDIR? install_root?
+ make -j1 install_root="$pkgdir" install
+}