summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Paden2020-05-15 23:45:08 -0500
committerAaron Paden2020-05-15 23:45:08 -0500
commit076bf1121cfdcb9376b2d178682928ed3cb3d2b8 (patch)
treeb69465352eb11a04e0d0358eb18cc7795b91a3b0
parent62ae5403de493f543259f27e40d03bcd260ff872 (diff)
downloadaur-076bf1121cfdcb9376b2d178682928ed3cb3d2b8.tar.gz
Workaround broken gcc 10 build.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--use-fcommon.patch12
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a45f12bdf4df..cfc80aec22b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pcem
pkgdesc = Emulator for various IBM PC computers and clones.
pkgver = 16
- pkgrel = 2
+ pkgrel = 3
url = http://pcem-emulator.co.uk/
arch = x86_64
arch = i686
@@ -11,7 +11,9 @@ pkgbase = pcem
depends = sdl2
depends = alsa-lib
source = http://pcem-emulator.co.uk/files/PCemV16Linux.tar.gz
+ source = use-fcommon.patch
sha256sums = 45ae9321ee25375f0e685a49d84e8a5acba8ed33ccf597299edcf287cb3c8499
+ sha256sums = a020184887520f58e74a8ebb990fb677af4d40dd87a5602f2336945824c7cea9
pkgname = pcem
diff --git a/PKGBUILD b/PKGBUILD
index 05af42c3452e..6b9003c5ec6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,23 @@
# Contributor: Natalia Portillo <claunia@clania.com>
pkgname=pcem
pkgver=16
-pkgrel=2
+pkgrel=3
pkgdesc="Emulator for various IBM PC computers and clones."
url="http://pcem-emulator.co.uk/"
arch=('x86_64' 'i686')
license=('GPL2')
depends=('wxgtk2' 'openal' 'sdl2' 'alsa-lib')
-source=("http://pcem-emulator.co.uk/files/PCemV${pkgver}Linux.tar.gz")
+source=("http://pcem-emulator.co.uk/files/PCemV${pkgver}Linux.tar.gz"
+ use-fcommon.patch)
+prepare() {
+ cd "${srcdir}"
+ # fix build with gcc 10
+ patch -p0 <../use-fcommon.patch
+}
build() {
cd "${srcdir}"
+ autoreconf
./configure --enable-alsa --enable-release-build --enable-networking --prefix=/usr
make
}
@@ -23,4 +30,5 @@ package() {
}
# vim:set ts=2 sw=2 et:
-sha256sums=('45ae9321ee25375f0e685a49d84e8a5acba8ed33ccf597299edcf287cb3c8499')
+sha256sums=('45ae9321ee25375f0e685a49d84e8a5acba8ed33ccf597299edcf287cb3c8499'
+ 'a020184887520f58e74a8ebb990fb677af4d40dd87a5602f2336945824c7cea9')
diff --git a/use-fcommon.patch b/use-fcommon.patch
new file mode 100644
index 000000000000..1cdb75909065
--- /dev/null
+++ b/use-fcommon.patch
@@ -0,0 +1,12 @@
+--- configure.ac 2020-05-15 23:33:55.534886733 -0500
++++ configure.ac2 2020-05-15 23:34:30.310669969 -0500
+@@ -31,8 +31,8 @@
+ CXXFLAGS="-Wall -O0 -g -D_DEBUG"
+ AC_MSG_RESULT([yes])
+ else
+- CFLAGS="-O3"
+- CXXFLAGS="-O3"
++ CFLAGS="-O3 -fcommon"
++ CXXFLAGS="-O3 -fcommon"
+ AC_MSG_RESULT([no])
+ fi