summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2019-11-22 08:05:18 +0100
committerJan Cholasta2019-11-22 08:13:49 +0100
commitc72e1c4e3518ffe98a4c59be5914b014a72c81a4 (patch)
tree2fb47c18675e78460683424be88d4a8d3baadca1
downloadaur-c72e1c4e3518ffe98a4c59be5914b014a72c81a4.tar.gz
pcexhumed-git-211119+6+g945391c-1
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
-rw-r--r--pcexhumed.desktop9
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07d07b5f8de8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = pcexhumed-git
+ pkgdesc = Exhumed / PowerSlave port based on EDuke32 (git version)
+ pkgver = 211119+6+g945391c
+ pkgrel = 1
+ url = https://gitlab.com/exhumed/exhumed
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom:BUILD
+ makedepends = git
+ makedepends = imagemagick
+ depends = flac
+ depends = glu
+ depends = gtk2
+ depends = libgl
+ depends = libogg
+ depends = libvorbis
+ depends = sdl2
+ depends = sdl2_mixer
+ depends = timidity++
+ provides = pcexhumed
+ conflicts = pcexhumed
+ source = exhumed::git+https://gitlab.com/exhumed/exhumed.git
+ source = pcexhumed.desktop
+ sha256sums = SKIP
+ sha256sums = deda95400d3e7b44078cac690fe6203280d0744ee14f523dd715eaf9f567f341
+ makedepends_i686 = nasm
+
+pkgname = pcexhumed-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e3ee61cee8b3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/exhumed
+/pkg
+/src
+/*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bc056f06bc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Jan Cholasta <jan at cholasta net>
+
+pkgname=pcexhumed-git
+pkgver=211119+6+g945391c
+pkgrel=1
+pkgdesc='Exhumed / PowerSlave port based on EDuke32 (git version)'
+arch=('i686' 'x86_64')
+url='https://gitlab.com/exhumed/exhumed'
+license=('GPL' 'custom:BUILD')
+depends=('flac'
+ 'glu'
+ 'gtk2'
+ 'libgl'
+ 'libogg'
+ 'libvorbis'
+ 'sdl2'
+ 'sdl2_mixer'
+ 'timidity++')
+makedepends=('git' 'imagemagick')
+makedepends_i686=('nasm')
+provides=('pcexhumed')
+conflicts=('pcexhumed')
+source=('exhumed::git+https://gitlab.com/exhumed/exhumed.git'
+ 'pcexhumed.desktop')
+sha256sums=('SKIP'
+ 'deda95400d3e7b44078cac690fe6203280d0744ee14f523dd715eaf9f567f341')
+
+pkgver() {
+ cd exhumed
+ git describe --tags --long | sed 's/^v//;s/-/+/g'
+}
+
+build() {
+ cd exhumed
+ make PACKAGE_REPOSITORY=1 REVFLAG="-DREV=\\\"$(git describe --tags --long)\\\""
+ MAGICK_OCL_DEVICE=OFF convert \
+ source/exhumed/rsrc/game_icon.ico\[10\] \
+ pcexhumed.png
+}
+
+package() {
+ cd exhumed
+ install -D -t "$pkgdir"/usr/bin pcexhumed
+ install -D -t "$pkgdir"/usr/share/licenses/$pkgname -m 644 package/common/buildlic.txt
+ install -D -t "$pkgdir"/usr/share/applications -m 644 "$srcdir"/pcexhumed.desktop
+ install -D -t "$pkgdir"/usr/share/icons/hicolor/256x256/apps -m 644 pcexhumed.png
+}
diff --git a/pcexhumed.desktop b/pcexhumed.desktop
new file mode 100644
index 000000000000..ed96f39cd1bb
--- /dev/null
+++ b/pcexhumed.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=PCExhumed
+GenericName=Exhumed / PowerSlave port based on EDuke32
+Icon=pcexhumed
+Exec=pxexhumed %F
+Terminal=false
+Categories=Game;ActionGame;