summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCebtenzzre2018-11-20 12:06:40 -0500
committerCebtenzzre2018-11-20 12:11:11 -0500
commit03600af2a07c4977ccb392572462068dd59f4536 (patch)
tree390b22c09d3b977515cc2a1729e8eaebdcb1a446
parentf6b2ae400d8ef93157c811c820ad5e8a9235579a (diff)
downloadaur-03600af2a07c4977ccb392572462068dd59f4536.tar.gz
Fix everything
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
-rw-r--r--fix-makefile.patch17
3 files changed, 34 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15819663a175..fbfb186ce786 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,14 +3,15 @@ pkgbase = pcg-cpp-git
pkgver = 0.98.1.r36.gb656278
pkgrel = 1
url = http://www.pcg-random.org/
- arch = x86_64
- arch = i686
+ arch = any
license = Apache
license = MIT
makedepends = git
provides = pcg-cpp
+ source = fix-makefile.patch
source = git+https://github.com/imneme/pcg-cpp.git
- md5sums = SKIP
+ sha256sums = 3867f1a75bf30b4aa73c2ab0b5e821fc8764a8d7bb20f6a44f12bc1b1477d361
+ sha256sums = SKIP
pkgname = pcg-cpp-git
diff --git a/PKGBUILD b/PKGBUILD
index 48257a3053ba..61de68f8391f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,14 @@ pkgname="${_pkgname}-git"
pkgver=0.98.1.r36.gb656278
pkgrel=1
pkgdesc='A family of fast, statistically excellent algorithms for random number generation.'
-arch=('x86_64' 'i686')
+arch=('any')
url='http://www.pcg-random.org/'
license=('Apache' 'MIT')
makedepends=('git')
-source=("git+https://github.com/imneme/${_pkgname}.git")
-md5sums=('SKIP')
+source=('fix-makefile.patch'
+ "git+https://github.com/imneme/${_pkgname}.git")
+sha256sums=('3867f1a75bf30b4aa73c2ab0b5e821fc8764a8d7bb20f6a44f12bc1b1477d361'
+ 'SKIP')
provides=("${_pkgname}")
pkgver() {
@@ -17,6 +19,11 @@ pkgver() {
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$_pkgname"
+ patch -Np1 <../fix-makefile.patch
+}
+
build() {
cd "$_pkgname"
make
@@ -29,5 +36,7 @@ check() {
package() {
cd "$_pkgname"
- make install DESTDIR="$pkgdir"
+ mkdir -p "$pkgdir/usr/include"
+ make install PREFIX="$pkgdir/usr"
+ install -m644 -D 'LICENSE-MIT.txt' "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
}
diff --git a/fix-makefile.patch b/fix-makefile.patch
new file mode 100644
index 000000000000..04c8fb1e73c2
--- /dev/null
+++ b/fix-makefile.patch
@@ -0,0 +1,17 @@
+diff --git a/Makefile b/Makefile
+index 21290ab..ccb9ce5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,10 +23,10 @@ all:
+ cd test-high; $(MAKE)
+ cd sample; $(MAKE)
+
+-PREFIX = /usr/local
++PREFIX ?= /usr/local
+
+ install: all
+- install -m 0644 include/*.hpp $PREFIX/include
++ install -m 0644 include/*.hpp $(PREFIX)/include
+
+ test: all
+ cd test-high; $(MAKE) test