summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCebtenzzre2018-11-20 12:00:52 -0500
committerCebtenzzre2018-11-20 12:00:52 -0500
commitf6b2ae400d8ef93157c811c820ad5e8a9235579a (patch)
tree73fdd724e534f0cd3340c509f71ae5a1d0326b9d
downloadaur-f6b2ae400d8ef93157c811c820ad5e8a9235579a.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15819663a175
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pcg-cpp-git
+ pkgdesc = A family of fast, statistically excellent algorithms for random number generation.
+ pkgver = 0.98.1.r36.gb656278
+ pkgrel = 1
+ url = http://www.pcg-random.org/
+ arch = x86_64
+ arch = i686
+ license = Apache
+ license = MIT
+ makedepends = git
+ provides = pcg-cpp
+ source = git+https://github.com/imneme/pcg-cpp.git
+ md5sums = SKIP
+
+pkgname = pcg-cpp-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48257a3053ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Cebtenzzre <cebtenzzre (at) gmail (dot) com>
+_pkgname=pcg-cpp
+pkgname="${_pkgname}-git"
+pkgver=0.98.1.r36.gb656278
+pkgrel=1
+pkgdesc='A family of fast, statistically excellent algorithms for random number generation.'
+arch=('x86_64' 'i686')
+url='http://www.pcg-random.org/'
+license=('Apache' 'MIT')
+makedepends=('git')
+source=("git+https://github.com/imneme/${_pkgname}.git")
+md5sums=('SKIP')
+provides=("${_pkgname}")
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+check() {
+ cd "$_pkgname"
+ make test
+}
+
+package() {
+ cd "$_pkgname"
+ make install DESTDIR="$pkgdir"
+}