summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-13 21:30:08 +0800
committerChocobo12017-08-13 22:56:34 +0800
commitac13119377f15d3a8104b279767bbaf5eb8bbb92 (patch)
tree4d6cd79aa97f889f8547712f8533cb61e6c30773
downloadaur-ac13119377f15d3a8104b279767bbaf5eb8bbb92.tar.gz
newpkg: pciutils-git 3.5.5.r0.gdfd15a8-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2364ed926e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pciutils-git
+ pkgdesc = Programs for inspecting and manipulating configuration of PCI devices
+ pkgver = 3.5.5.r0.gdfd15a8
+ pkgrel = 1
+ url = http://mj.ucw.cz/sw/pciutils/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ depends = hwids
+ depends = kmod
+ provides = pciutils
+ conflicts = pciutils
+ source = git+https://git.kernel.org/pub/scm/utils/pciutils/pciutils.git
+ sha256sums = SKIP
+
+pkgname = pciutils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..992cd9523ca3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=pciutils-git
+pkgver=3.5.5.r0.gdfd15a8
+pkgrel=1
+pkgdesc="Programs for inspecting and manipulating configuration of PCI devices"
+arch=('i686' 'x86_64')
+url="http://mj.ucw.cz/sw/pciutils/"
+license=('GPL2')
+depends=('glibc' 'hwids' 'kmod')
+makedepends=('git')
+provides=('pciutils')
+conflicts=('pciutils')
+source=("git+https://git.kernel.org/pub/scm/utils/pciutils/pciutils.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "pciutils"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+_OPTIONS='SHARED=yes ZLIB=no'
+build() {
+ cd "pciutils"
+
+ make OPT="$CFLAGS" "$_OPTIONS"
+}
+
+package() {
+ cd "pciutils"
+
+ make DESTDIR="$pkgdir" PREFIX="/usr" SBINDIR="/usr/bin" SHAREDIR="/usr/share/hwdata" "$_OPTIONS" install install-lib
+
+ # supplied by hwids package
+ rm -rf "$pkgdir/usr/share/hwdata"
+}