summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordaizhirui2023-08-06 15:11:11 -0700
committerdaizhirui2023-08-06 15:11:11 -0700
commitceea46b5acc01e01e0a9147f1522cbfc821e8bd4 (patch)
tree956ea5c6dbab0c26d5e83518366f4b3b1ba44987
parentba193ab9b05cba07b20f02075a392c02b319489c (diff)
downloadaur-ceea46b5acc01e01e0a9147f1522cbfc821e8bd4.tar.gz
fix build with GNU13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
-rw-r--r--cassert.patch148
3 files changed, 177 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1d7797dd1d2c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+pcl
+pcl*tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index b8320c249844..d5cc6a12ae8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: lubosz
pkgname=pcl-git
-pkgver=r13641.c1835f442
+pkgver=r14183.de6d7151d
pkgrel=1
pkgdesc="a standalone, large scale, open project for 2D/3D image and point cloud processing"
arch=(i686 x86_64)
@@ -27,10 +27,24 @@ depends=(
vtk
pugixml
fmt
+ python-mpi4py
+ openxr
+ openvr
+ gl2ps
+ adios2
+ verdict
+ liblas
+ openvdb
+ pdal
+ openimagedenoise
+ ospray
+ cli11
+ utf8cpp
+ nlohmann-json
)
makedepends=(cmake git)
-source=(git+https://github.com/PointCloudLibrary/pcl)
-sha256sums=(SKIP)
+source=(git+https://github.com/PointCloudLibrary/pcl cassert.patch)
+sha256sums=(SKIP SKIP)
conflicts=(pcl)
provides=(pcl)
@@ -41,6 +55,9 @@ pkgver() {
}
prepare() {
+ cd "$srcdir/pcl"
+ patch -p1 -i ../../cassert.patch
+
rm -rf "$srcdir/build"
mkdir "$srcdir/build"
cd "$srcdir/build"
@@ -67,12 +84,15 @@ prepare() {
-DBUILD_gpu_kinfu_large_scale=OFF \
-DBUILD_gpu_surface=ON \
-DBUILD_gpu_tracking=ON \
- -DBUILD_simulation=ON
+ -DBUILD_simulation=ON \
+ -DCMAKE_CUDA_COMPILER=/opt/cuda/bin/nvcc \
+ -DCMAKE_MODULE_PATH=/usr/lib/cmake/OpenVDB \
+ -DWITH_QT=QT5
}
build() {
cd "$srcdir/build"
- make
+ make -j$(nproc)
}
package() {
diff --git a/cassert.patch b/cassert.patch
new file mode 100644
index 000000000000..453a7bbabfb5
--- /dev/null
+++ b/cassert.patch
@@ -0,0 +1,148 @@
+diff --git a/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/command.h b/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/command.h
+index e7dbdedd3..ca4ef7fb1 100644
+--- a/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/command.h
++++ b/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/command.h
+@@ -43,6 +43,8 @@
+
+ #include <pcl/apps/point_cloud_editor/localTypes.h>
+
++#include <cassert>
++
+ /// @brief The abstract parent class of all the command classes. Commands are
+ /// non-copyable.
+ class Command
+diff --git a/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/commandQueue.h b/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/commandQueue.h
+index 93433339c..f69d9fa05 100644
+--- a/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/commandQueue.h
++++ b/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/commandQueue.h
+@@ -41,6 +41,7 @@
+
+ #pragma once
+
++#include <cassert>
+ #include <deque>
+ #include <pcl/apps/point_cloud_editor/localTypes.h>
+
+diff --git a/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/select1DTool.h b/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/select1DTool.h
+index fc21d80aa..ee34d7d75 100644
+--- a/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/select1DTool.h
++++ b/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/select1DTool.h
+@@ -44,6 +44,8 @@
+
+ #include <pcl/memory.h> // for pcl::shared_ptr
+
++#include <cassert>
++
+ class Selection;
+
+ class Select1DTool : public ToolInterface
+diff --git a/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/statistics.h b/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/statistics.h
+index 8618e4b96..80d3fc474 100644
+--- a/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/statistics.h
++++ b/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/statistics.h
+@@ -42,6 +42,7 @@
+
+ #include <vector>
+ #include <string>
++#include <cassert>
+ #include <pcl/apps/point_cloud_editor/localTypes.h>
+
+ class Statistics
+diff --git a/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/toolInterface.h b/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/toolInterface.h
+index c5cc67c89..38111acba 100644
+--- a/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/toolInterface.h
++++ b/apps/point_cloud_editor/include/pcl/apps/point_cloud_editor/toolInterface.h
+@@ -43,6 +43,8 @@
+
+ #include <pcl/apps/point_cloud_editor/localTypes.h>
+
++#include <cassert>
++
+ /// @brief the parent class of all the select and the transform tool classes
+ class ToolInterface
+ {
+diff --git a/common/include/pcl/common/impl/gaussian.hpp b/common/include/pcl/common/impl/gaussian.hpp
+index 3b9c20b22..f8ecab25c 100644
+--- a/common/include/pcl/common/impl/gaussian.hpp
++++ b/common/include/pcl/common/impl/gaussian.hpp
+@@ -40,6 +40,7 @@
+ #pragma once
+
+ #include <pcl/common/gaussian.h>
++#include <cassert>
+
+ namespace pcl
+ {
+diff --git a/common/src/colors.cpp b/common/src/colors.cpp
+index 4d53ab130..77970055f 100644
+--- a/common/src/colors.cpp
++++ b/common/src/colors.cpp
+@@ -38,6 +38,7 @@
+ #include <pcl/point_types.h>
+ #include <pcl/common/colors.h>
+
++#include <cassert>
+ #include <array>
+
+ /// Glasbey lookup table
+diff --git a/common/src/gaussian.cpp b/common/src/gaussian.cpp
+index 69bbd1253..2b6a66716 100644
+--- a/common/src/gaussian.cpp
++++ b/common/src/gaussian.cpp
+@@ -36,6 +36,7 @@
+ */
+
+ #include <pcl/common/gaussian.h>
++#include <cassert>
+
+ void
+ pcl::GaussianKernel::compute (float sigma,
+diff --git a/common/src/range_image_planar.cpp b/common/src/range_image_planar.cpp
+index 784c40ccb..206288016 100644
+--- a/common/src/range_image_planar.cpp
++++ b/common/src/range_image_planar.cpp
+@@ -34,6 +34,7 @@
+
+ /** \author Bastian Steder */
+
++#include <cassert>
+ #include <iostream>
+ using std::cout;
+ using std::cerr;
+diff --git a/geometry/include/pcl/geometry/mesh_base.h b/geometry/include/pcl/geometry/mesh_base.h
+index d9346bab9..b27abc909 100644
+--- a/geometry/include/pcl/geometry/mesh_base.h
++++ b/geometry/include/pcl/geometry/mesh_base.h
+@@ -50,6 +50,7 @@
+
+ #include <type_traits>
+ #include <vector>
++#include <cassert>
+
+ ////////////////////////////////////////////////////////////////////////////////
+ // Global variables used during testing
+diff --git a/gpu/features/src/features.cpp b/gpu/features/src/features.cpp
+index cefd88b69..a0172c3a2 100644
+--- a/gpu/features/src/features.cpp
++++ b/gpu/features/src/features.cpp
+@@ -41,6 +41,8 @@
+ #include <pcl/exceptions.h>
+ #include <pcl/console/print.h>
+
++#include <cassert>
++
+ using namespace pcl::device;
+
+ /////////////////////////////////////////////////////////////////////////
+diff --git a/kdtree/include/pcl/kdtree/kdtree.h b/kdtree/include/pcl/kdtree/kdtree.h
+index d8d4e4bdd..fd5e357fb 100644
+--- a/kdtree/include/pcl/kdtree/kdtree.h
++++ b/kdtree/include/pcl/kdtree/kdtree.h
+@@ -43,6 +43,7 @@
+ #include <pcl/point_cloud.h>
+ #include <pcl/point_representation.h>
+ #include <pcl/common/copy_point.h>
++#include <cassert>
+
+ namespace pcl
+ {