summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquomoow2016-10-21 21:47:06 +0000
committerquomoow2016-10-21 21:47:06 +0000
commit1aace4bc4b08370379a023abeec0bc6ab2df93f1 (patch)
tree064bf027b03b4a9f56e838b672931c53ddce5a2f
parentef228ce43cb659d636bf8b63c3a1b63eafdb239f (diff)
downloadaur-1aace4bc4b08370379a023abeec0bc6ab2df93f1.tar.gz
Updated, should fully work
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD48
-rw-r--r--pcmanfm.install12
3 files changed, 28 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b46e54d2d64a..f6b028dd81d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,22 @@
-# Generated by makepkg 4.2.1
-# Mon Jun 1 13:54:21 UTC 2015
pkgbase = pcmanfm-git
pkgdesc = An extremely fast, lightweight, yet feature-rich file manager with tabbed browsing
- pkgver = 1.2.1.r3.g8a2c79c
+ pkgver = 0.0.0.0
pkgrel = 1
url = http://pcmanfm.sourceforge.net/
- install = pcmanfm.install
arch = i686
arch = x86_64
license = GPL
makedepends = git
makedepends = intltool
makedepends = pkg-config
- depends = libfm-gtk-git
+ depends = libfm-gtk2
+ optdepends = gnome-menus: applications menu and "Open with" dialog
optdepends = gvfs: mounting of local and remote drives
optdepends = lxmenu-data: applications menu and "Open with" dialog
- optdepends = gnome-menus: applications menu and "Open with" dialog
provides = pcmanfm
conflicts = pcmanfm
- source = git://git.lxde.org/git/lxde/pcmanfm
- source = pcmanfm.install
+ source = git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm
md5sums = SKIP
- md5sums = fc9ea2af71f55f32c8b22bf5ea879e69
pkgname = pcmanfm-git
diff --git a/PKGBUILD b/PKGBUILD
index 2850656ffa65..586b48f979f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,40 @@
+# Maintainer: quomoow <quomoow@gmail.com>
pkgname=pcmanfm-git
-pkgver=1.2.1.r3.g8a2c79c
+_pkgname=pcmanfm
+pkgver=0.0.0.0
pkgrel=1
-
-pkgdesc="An extremely fast, lightweight, yet feature-rich file manager with tabbed browsing"
-url="http://pcmanfm.sourceforge.net/"
+pkgdesc="An extremely fast, lightweight, yet feature-rich file manager with
+tabbed browsing"
arch=('i686' 'x86_64')
+url="http://pcmanfm.sourceforge.net/"
license=('GPL')
-
-depends=('libfm-gtk-git')
+depends=('libfm-gtk2')
makedepends=('git' 'intltool' 'pkg-config')
-optdepends=('gvfs: mounting of local and remote drives'
- 'lxmenu-data: applications menu and "Open with" dialog'
- 'gnome-menus: applications menu and "Open with" dialog')
-
+optdepends=('gnome-menus: applications menu and "Open with" dialog'
+ 'gvfs: mounting of local and remote drives'
+ 'lxmenu-data: applications menu and "Open with" dialog')
provides=('pcmanfm')
conflicts=('pcmanfm')
+source=(git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm)
+md5sums=('SKIP')
-install=pcmanfm.install
-source=('git://git.lxde.org/git/lxde/pcmanfm'
- pcmanfm.install)
-
-md5sums=('SKIP'
- 'fc9ea2af71f55f32c8b22bf5ea879e69')
+prepare() {
+ cd "${_pkgname}"
-pkgver() {
- cd pcmanfm
- git describe --always --long | sed 's/-/-r/; s/-/./g'
+ ./autogen.sh
}
build() {
- cd pcmanfm
- ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc
- make LDFLAGS="-lm ${LDFLAGS}"
+ cd "${_pkgname}"
+
+ ./configure --prefix=/usr --sysconfdir=/etc
+
+ make
}
package() {
- make -C pcmanfm DESTDIR="$pkgdir" install
+ cd "${_pkgname}"
+
+ make DESTDIR="${pkgdir}/" install
}
+
diff --git a/pcmanfm.install b/pcmanfm.install
deleted file mode 100644
index 2eef14436acd..000000000000
--- a/pcmanfm.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- update-mime-database usr/share/mime > /dev/null
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}