summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElrondo462018-04-22 17:06:14 +0200
committerElrondo462018-04-22 17:06:14 +0200
commiteb3d0d6f400914b45933278e6017078ebccf0a95 (patch)
tree6f409f6fbf4fed32690ed1a15a7a3827ee6bec02
downloadaur-eb3d0d6f400914b45933278e6017078ebccf0a95.tar.gz
First Version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--org.tnv.pcmanfmpolk.policy24
-rwxr-xr-xpcmanfmroot.desktop11
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4cdedd9a728
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pcmanfm-gtk3-root
+ pkgdesc = Caja with admin rights with polkit
+ pkgver = 1.2.5
+ pkgrel = 1
+ url = https://www.tuxnvape.fr/
+ arch = x86_64
+ license = GPL3
+ depends = pcmanfm-gtk3
+ source = pcmanfmroot.desktop
+ source = org.tnv.pcmanfmpolk.policy
+ sha256sums = d2ea3cb2a69230c9f50622fb3e2d9de3692a127118da570b01513ed08b21dfa7
+ sha256sums = 51d70cbd7a4078ec91397f6f227a692af37015af7cf6c91d606b5449640588fd
+
+pkgname = pcmanfm-gtk3-root
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bb009097406
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Elrondo46 TuxnVape <elrond94@hotmail.com>
+
+pkgname=pcmanfm-gtk3-root
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="Caja with admin rights with polkit"
+arch=('x86_64')
+license=('GPL3')
+url="https://www.tuxnvape.fr/"
+depends=('pcmanfm-gtk3')
+
+source=("pcmanfmroot.desktop"
+ "org.tnv.pcmanfmpolk.policy")
+
+sha256sums=('d2ea3cb2a69230c9f50622fb3e2d9de3692a127118da570b01513ed08b21dfa7'
+ '51d70cbd7a4078ec91397f6f227a692af37015af7cf6c91d606b5449640588fd')
+
+package() {
+ install -Dm644 "pcmanfmroot.desktop" "${pkgdir}/usr/share/applications/pcmanfmroot.desktop"
+ install -Dm644 "org.tnv.pcmanfmpolk.policy" "${pkgdir}/usr/share/polkit-1/actions/org.tnv.pcmanfmpolk.policy"
+}
+
diff --git a/org.tnv.pcmanfmpolk.policy b/org.tnv.pcmanfmpolk.policy
new file mode 100644
index 000000000000..875e506d7260
--- /dev/null
+++ b/org.tnv.pcmanfmpolk.policy
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE policyconfig PUBLIC
+"-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
+"http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
+<policyconfig>
+
+ <vendor>TuxnVape</vendor>
+ <vendor_url>http://www.tuxnvape.fr</vendor_url>
+
+ <action id="org.tnv.pcmanfmpolk.pkexec.run">
+ <description>Run PCManFM in superuser mode</description>
+ <description xml:lang="fr">Lance PCManFM avec les droits root</description>
+ <message>Admin right are required to launch PCManFM in superuser mode</message>
+ <message xml:lang="fr">Les droits d'administration sont nécessaires pour lancer PCManFM en root </message>
+ <icon_name>system-file-manager</icon_name>
+ <defaults>
+ <allow_any>no</allow_any>
+ <allow_inactive>no</allow_inactive>
+ <allow_active>auth_admin_keep</allow_active>
+ </defaults>
+ <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/pcmanfm</annotate>
+ <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
+ </action>
+</policyconfig>
diff --git a/pcmanfmroot.desktop b/pcmanfmroot.desktop
new file mode 100755
index 000000000000..f35219ab7703
--- /dev/null
+++ b/pcmanfmroot.desktop
@@ -0,0 +1,11 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Type=Application
+Terminal=false
+Categories=System;
+Icon=system-file-manager
+Icon[fr_FR]=system-file-manager
+Name[fr_FR]=PCManFM (SuperUtilisateur)
+Exec=pkexec /usr/bin/pcmanfm
+Name=PCManFM (SU)