summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2017-07-06 20:35:42 -0400
committerChris Severance2017-07-06 20:35:42 -0400
commitbd223d1588c2c89f2afeb26d36614390e9c67fe5 (patch)
tree1fc541d8d4519734364831a1dbb886d186f52878
parentbf1c7aa137f5925e30c7206528535117faeb46f5 (diff)
downloadaur-bd223d1588c2c89f2afeb26d36614390e9c67fe5.tar.gz
Update to 8.41
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 7 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84e17e202f07..546a09ef0e6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jan 12 16:41:13 UTC 2017
+# Fri Jul 7 00:35:42 UTC 2017
pkgbase = pcre-svn
pkgdesc = A regex library that implements Perl 5-style regular expressions, includes pcregrep
- pkgver = 8.40.r1675
+ pkgver = 8.41.r1707
pkgrel = 1
url = http://www.pcre.org/
arch = i686
@@ -16,7 +16,7 @@ pkgbase = pcre-svn
depends = zlib
depends = bzip2
depends = bash
- provides = pcre=8.40
+ provides = pcre=8.41
conflicts = pcre
source = pcre-svn::svn://vcs.exim.org/pcre/code/trunk
source = 01-seven-security-patches.patch::https://projects.archlinux.org/svntogit/packages.git/plain/trunk/01-seven-security-patches.patch?h=packages/pcre
diff --git a/PKGBUILD b/PKGBUILD
index d8de5687aa52..dc7aa5c39cc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ set -u
_pkgname='pcre'
pkgname="${_pkgname}-svn"
_srcdir="${pkgname}"
-pkgver=8.40.r1675
+pkgver=8.41.r1707
pkgrel=1
pkgdesc='A regex library that implements Perl 5-style regular expressions, includes pcregrep'
arch=('i686' 'x86_64')
@@ -56,14 +56,15 @@ prepare() {
build() {
set -u
cd "${_srcdir}"
- make -s -j $(nproc)
+ local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
+ nice make -s -j "${_nproc}"
set +u
}
check() {
set -u
cd "${_srcdir}"
- make -s -j $(nproc) check
+ make -s -j1 check
set +u
}
@@ -74,17 +75,6 @@ package() {
install -Dpm644 'LICENCE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
set +u
- # Ensure there are no forbidden paths. Place at the end of package() and comment out as you find or need exceptions. (git-aurcheck)
- ! test -d "${pkgdir}/bin" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
- ! test -d "${pkgdir}/sbin" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
- ! test -d "${pkgdir}/lib" || { echo "Line ${LINENO} Forbidden: /lib"; false; }
- ! test -d "${pkgdir}/share" || { echo "Line ${LINENO} Forbidden: /share"; false; }
- ! test -d "${pkgdir}/usr/sbin" || { echo "Line ${LINENO} Forbidden: /usr/sbin"; false; }
- ! test -d "${pkgdir}/usr/local" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
- ! grep -lr "/sbin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
- ! grep -lr "/usr/tmp" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/tmp"; false; }
- #! grep -lr "/usr/local" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
- #! pcre2grep -Ilr "(?<!/usr)/bin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /bin"; false; } # 1 script has /bin/sh
}
set +u