summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2018-01-28 17:37:36 -0700
committerBrian Bidulock2018-01-28 17:37:36 -0700
commit73695c7714bc9965c1957fec9c8dab5e4ec3c809 (patch)
treeaa590b0ba1eb7047ca0c24a6db7c90798cba1083
parentd9fee38ca2d057b032c1438ecdb074b3437bd35e (diff)
downloadaur-73695c7714bc9965c1957fec9c8dab5e4ec3c809.tar.gz
uppkg
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c76deafe68d..5104386ccfd2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = pcs
pkgdesc = pacemaker corosync shell utility for cluster configuration
- pkgver = 0.9.157
- pkgrel = 1
+ pkgver = 0.9.162
+ pkgrel = 2
url = http://clusterlabs.org/
arch = any
license = GPL2
makedepends = ruby-bundler
+ makedepends = wget
depends = python
depends = python-lxml
- source = https://github.com/ClusterLabs/pcs/archive/0.9.157.tar.gz
- md5sums = 9e235349882b3090d4a9f09ffdd4656b
+ depends = python-setuptools
+ source = https://github.com/ClusterLabs/pcs/archive/0.9.162.tar.gz
+ sha512sums = 9616487e89882b2bf5007fb61adad4af88e164d003fd6401924fbff10c811ac1873607013226b4032ac4efaa5df5b36f5a39c8edafd572a7c2241855de39df18
pkgname = pcs
diff --git a/PKGBUILD b/PKGBUILD
index cc74ca81ce2a..35de2ed6b736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,25 @@
# Contributor: Noel Kuntze <noel@familie-kuntze.de>
pkgname=pcs
-pkgver=0.9.157
-pkgrel=1
+pkgver=0.9.162
+pkgrel=2
pkgdesc='pacemaker corosync shell utility for cluster configuration'
arch=('any')
url='http://clusterlabs.org/'
license=('GPL2')
-depends=('python' 'python-lxml')
-makedepends=('ruby-bundler')
+depends=('python' 'python-lxml' 'python-setuptools')
+makedepends=('ruby-bundler' 'wget')
source=("https://github.com/ClusterLabs/$pkgname/archive/$pkgver.tar.gz")
-md5sums=('9e235349882b3090d4a9f09ffdd4656b')
+sha512sums=('9616487e89882b2bf5007fb61adad4af88e164d003fd6401924fbff10c811ac1873607013226b4032ac4efaa5df5b36f5a39c8edafd572a7c2241855de39df18')
-build() {
- cd $pkgname-$pkgver
- make -C pcsd BUILD_GEMS=true build_gems
-}
+#build() {
+# cd $pkgname-$pkgver
+# make -C pcsd BUILD_GEMS=true build_gems
+#}
package() {
cd $pkgname-$pkgver
- make DESTDIR="${pkgdir}" BUILD_GEMS=false install install_pcsd
+ make DESTDIR="${pkgdir}" install
rm -fr "${pkgdir}/usr/bin"
mv "${pkgdir}/usr/sbin" "${pkgdir}/usr/bin"
}