summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:08:49 +0100
committerSteven Honeyman2015-06-09 19:08:49 +0100
commitaae47ee53894cf12fc718ce825fba5dde323eb72 (patch)
treea9dc02e908dfb7bd1735d8bbde3f4da2f38e5258
downloadaur-aae47ee53894cf12fc718ce825fba5dde323eb72.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
3 files changed, 53 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..1ff2c8b8abbc
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = pcspk
+ pkgdesc = A set of command line applications for using the PC speaker
+ pkgver = 0.0.6
+ pkgrel = 2
+ url = https://github.com/przemoc/pcspk
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ source = http://download.przemoc.net/pcspk-0.0.6.tar.gz
+ options = strip
+ options = !buildflags
+
+pkgname = pcspk
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d8a391cd10d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pcspk
+ pkgdesc = A set of command line applications for using the PC speaker
+ pkgver = 0.0.6
+ pkgrel = 2
+ url = https://github.com/przemoc/pcspk
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ options = strip
+ options = !buildflags
+ source = http://download.przemoc.net/pcspk-0.0.6.tar.gz
+ md5sums = 41b4e81c3c6c56e6171b746049a688a1
+
+pkgname = pcspk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bd414f4cef0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+# Contributor: rabyte <rabyte*gmail>
+
+pkgname=pcspk
+pkgver=0.0.6
+pkgrel=2
+pkgdesc="A set of command line applications for using the PC speaker"
+arch=('i686' 'x86_64')
+url="https://github.com/przemoc/pcspk"
+license=('GPL2')
+options=('strip' '!buildflags')
+source=(http://download.przemoc.net/$pkgname-$pkgver.tar.gz)
+md5sums=('41b4e81c3c6c56e6171b746049a688a1')
+
+build() {
+ cd $pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ mkdir -p $pkgdir/usr/{s,}bin
+ make PREFIX=$pkgdir/usr install
+} \ No newline at end of file