summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralgebro2021-01-07 11:36:05 -0500
committeralgebro2021-01-07 11:36:05 -0500
commit0e956a715884128b632c8acc3a0f0eafaee585bf (patch)
tree21ff4aef5138aecc8b6fb221830d2f158a277d8d
parent2691f266fbe7cfc7333ada8ea5b0087bb3d9a339 (diff)
downloadaur-0e956a715884128b632c8acc3a0f0eafaee585bf.tar.gz
packaging improvements
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--pcsx-redux.desktop6
-rw-r--r--pcsx-redux.sh2
4 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a34a7e40cbb6..7d5ca448a316 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pcsx-redux-git
- pkgdesc = Modern fork of the pcsxr Playstation 1 emulator that focuses on reverse engineering and homebrew development
- pkgver = r1270.109d9f9
- pkgrel = 2
+ pkgdesc = Modern fork of the pcsxr PlayStation 1 emulator focused on reverse engineering and homebrew development
+ pkgver = r1272.6c73f79
+ pkgrel = 1
url = https://github.com/grumpycoders/pcsx-redux.git
arch = x86_64
license = GPL2
@@ -9,12 +9,10 @@ pkgbase = pcsx-redux-git
makedepends = git
makedepends = make
makedepends = pkg-config
- depends = curl
depends = ffmpeg
depends = glfw-x11
depends = libuv
depends = sdl2
- depends = xorg-server-xvfb
depends = zlib
source = pcsx-redux::git+https://github.com/grumpycoders/pcsx-redux.git
source = git+https://github.com/ocornut/imgui.git
@@ -29,6 +27,7 @@ pkgbase = pcsx-redux-git
source = git+https://github.com/serge1/ELFIO.git
source = git+https://github.com/exoticlibraries/libcester.git
source = pcsx-redux.sh
+ source = pcsx-redux.desktop
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -41,7 +40,8 @@ pkgbase = pcsx-redux-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = f2869575cc7a4132a2c1d56ea504b20bb6a8185d663711313116ad51b6a8fd12
+ sha256sums = 21db8ce528f3240388d55d1f309ebc6060bb1145cce50553659e73fb6f89d326
+ sha256sums = 9061d4428ba69e06e3a540df6700a637cc28e740f95b07ca46f2cbcc8cdd347c
pkgname = pcsx-redux-git
diff --git a/PKGBUILD b/PKGBUILD
index b2c2575ac9c1..91166c956356 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,16 @@
pkgname=pcsx-redux-git
_pkgname=pcsx-redux
-pkgver=r1270.109d9f9
-pkgrel=2
-pkgdesc='Modern fork of the pcsxr Playstation 1 emulator that focuses on reverse engineering and homebrew development'
+pkgver=r1272.6c73f79
+pkgrel=1
+pkgdesc='Modern fork of the pcsxr PlayStation 1 emulator focused on reverse engineering and homebrew development'
arch=('x86_64')
url='https://github.com/grumpycoders/pcsx-redux.git'
license=('GPL2')
-depends=('curl'
- 'ffmpeg'
+depends=('ffmpeg'
'glfw-x11'
'libuv'
'sdl2'
- 'xorg-server-xvfb'
'zlib'
)
makedepends=('clang'
@@ -34,6 +32,7 @@ source=("${_pkgname}::git+https://github.com/grumpycoders/pcsx-redux.git"
'git+https://github.com/serge1/ELFIO.git'
'git+https://github.com/exoticlibraries/libcester.git'
'pcsx-redux.sh'
+ 'pcsx-redux.desktop'
)
sha256sums=('SKIP'
'SKIP'
@@ -47,7 +46,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'f2869575cc7a4132a2c1d56ea504b20bb6a8185d663711313116ad51b6a8fd12')
+ '21db8ce528f3240388d55d1f309ebc6060bb1145cce50553659e73fb6f89d326'
+ '9061d4428ba69e06e3a540df6700a637cc28e740f95b07ca46f2cbcc8cdd347c')
pkgver() {
cd "$_pkgname"
@@ -89,5 +89,6 @@ build() {
package() {
install -Dm755 pcsx-redux.sh "$pkgdir/usr/bin/pcsx-redux"
+ install -Dm644 pcsx-redux.desktop "$pkgdir/usr/share/applications/pcsx-redux.desktop"
install -Dm755 "$_pkgname/pcsx-redux" "$pkgdir/opt/pcsx-redux/pcsx-redux"
}
diff --git a/pcsx-redux.desktop b/pcsx-redux.desktop
new file mode 100644
index 000000000000..62ec06c7be8d
--- /dev/null
+++ b/pcsx-redux.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Type=Application
+Name=pcsx-redux
+Comment=PlayStation Emulator
+Terminal=false
+Exec=/usr/bin/pcsx-redux \ No newline at end of file
diff --git a/pcsx-redux.sh b/pcsx-redux.sh
index 76f0c5145a85..ea6238f6b410 100644
--- a/pcsx-redux.sh
+++ b/pcsx-redux.sh
@@ -2,4 +2,4 @@
DATADIR="$HOME/.pcsx-redux"
mkdir -p "$DATADIR"
-cd "$DATADIR" && /opt/pcsx-redux/pcsx-redux \ No newline at end of file
+cd "$DATADIR" && /opt/pcsx-redux/pcsx-redux "$@" \ No newline at end of file