summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoone2020-12-14 18:23:23 -0500
committernoone2020-12-14 18:23:23 -0500
commitad222ada800ae7ef0110ca19695fe01706706ed2 (patch)
treeadf045d71c326d898c7cced5461564196e9ed351
downloadaur-ad222ada800ae7ef0110ca19695fe01706706ed2.tar.gz
initial AUR commit
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD95
2 files changed, 144 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88fdd73629a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = pcsx2-64bit-git
+ pkgdesc = A Sony PlayStation 2 emulator, 64bit git master
+ pkgver = 1.7.0.r685.678829a5b
+ pkgrel = 1
+ url = https://www.pcsx2.net
+ arch = x86_64
+ license = GPL2
+ license = GPL3
+ license = LGPL2.1
+ license = LGPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = ninja
+ makedepends = png++
+ depends = gdk-pixbuf2
+ depends = glibc
+ depends = libaio
+ depends = libasound.so
+ depends = libfmt.so
+ depends = libfreetype.so
+ depends = libgdk-3.so
+ depends = libgio-2.0.so
+ depends = libgl
+ depends = libGLEW.so
+ depends = libglib-2.0.so
+ depends = libgobject-2.0.so
+ depends = libgtk-3.so
+ depends = libpcap
+ depends = libpng
+ depends = libportaudio.so
+ depends = libpulse.so
+ depends = libudev.so
+ depends = libx11
+ depends = libxcb
+ depends = libxml2
+ depends = libyaml-cpp.so
+ depends = sdl2
+ depends = soundtouch
+ depends = wxgtk3
+ depends = wxgtk-common
+ depends = xz
+ depends = zlib
+ provides = pxsx2
+ conflicts = pcsx2
+ source = git+https://github.com/PCSX2/pcsx2.git
+ b2sums = SKIP
+
+pkgname = pcsx2-64bit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26f9d63c70a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,95 @@
+# Maintainer: LaserEyess <lasereyess@lasereyess.net>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: josephgbr <rafael.f.f1@gmail.com>
+# Contributor: vEX <vex@niechift.com>
+
+pkgname=pcsx2-64bit-git
+pkgver=1.7.0.r685.678829a5b
+pkgrel=1
+pkgdesc='A Sony PlayStation 2 emulator, 64bit git master'
+arch=(x86_64)
+url=https://www.pcsx2.net
+license=(
+ GPL2
+ GPL3
+ LGPL2.1
+ LGPL3
+)
+
+depends=(
+ gdk-pixbuf2
+ glibc
+ libaio
+ libasound.so
+ libfmt.so
+ libfreetype.so
+ libgdk-3.so
+ libgio-2.0.so
+ libgl
+ libGLEW.so
+ libglib-2.0.so
+ libgobject-2.0.so
+ libgtk-3.so
+ libpcap
+ libpng
+ libportaudio.so
+ libpulse.so
+ libudev.so
+ libx11
+ libxcb
+ libxml2
+ libyaml-cpp.so
+ sdl2
+ soundtouch
+ wxgtk3
+ wxgtk-common
+ xz
+ zlib
+)
+makedepends=(
+ cmake
+ git
+ ninja
+ png++
+)
+source=(git+https://github.com/PCSX2/pcsx2.git)
+b2sums=(SKIP)
+
+provides=(pxsx2)
+conflicts=(pcsx2)
+
+pkgver() {
+ cd pcsx2
+
+ git describe --tags | sed 's/^v//; s/-dev//; s/-/.r/; s/-g/./'
+}
+
+build() {
+ cmake -S pcsx2 -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DDOC_DIR=/usr/share/doc/pcsx2 \
+ -DGAMEINDEX_DIR=/usr/share/pcsx2 \
+ -DPLUGIN_DIR=/usr/lib/pcsx2 \
+ -DDISABLE_ADVANCE_SIMD=ON \
+ -DDISABLE_BUILD_DATE=ON \
+ -DDISABLE_PCSX2_WRAPPER=ON \
+ -DENABLE_TESTS=OFF \
+ -DEXTRA_PLUGINS=ON \
+ -DSDL2_API=ON \
+ -DPACKAGE_MODE=ON \
+ -DREBUILD_SHADER=ON \
+ -DUSE_LTO=OFF \
+ -DUSE_VTUNE=OFF \
+ -DXDG_STD=ON \
+ -DUSE_SYSTEM_YAML=ON \
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
+ -Wno-dev
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+
+# vim: ts=2 sw=2 et: